Windows Deployment with QML (simple?) issue

  • Moderators

    Hello everyone,

    I'm about to deploy my first QML-based programm (on Windows) and I run into a problem.

    I'm using the windeployqt tool with the --qmldir <path\to\folder\that\contains\main.qml> - option. That does seem to work, as the folders qmltooling, Qt, QtGraphicalEffects, QtQml, QtQuick, QtQuick.2 and scenegraph have been added additionally to the normal bearer, platforms, translations etc folders.

    However I'm unable to start my programm, calling echo %errorlevel% returns -1073741819, which does not help much.

    The program is written with Qt 5.9.3(MSVC) and I'm using the windeploytool from that folder

    The QML-Files are part of my ressource file qml.qrc and are therefore part of the binary (?), I have not copied them anywhere into the "release-folder".

    I'm able to run my program without issue out of the QtCreator, therefore I'm sure, its a simple issue, that I'm unable to see, so any help is appreciated.

  • Lifetime Qt Champion


    Did you check with Dependency Walker whether there's something missing ?

  • Moderators

    @SGaist I actually did, and forgot to post that. Nothing striking showed up.

    I should mention, that "Splash.exe" a pure cpp programm starts and runs fine.

    I ended up copying all dlls by hand and now it works.

    The normal dll's where the correct ones, or Splash.exe would not have run otherwise, so I assume windeployqt copied the wrong QML-dependent dlls. I have more than one Qt-Installation (5.7, 5.9 5.10 MSVC & mingw).

    Sadly not the first time I had such an issue with the windeployqt tool.

  • Lifetime Qt Champion

    What was missing ?

  • Moderators

    @SGaist I'm not sure,
    if you look at the picture I posted, I copied, by hand, the folders qmltooling, Qt, QtGraphicalEffects, QtQML, QtQuick, QtQuick.2, and scenegraph and than it worked.

    So anyone of them, or all auf them?

Log in to reply