Update OS ( linux lubuntu ) and drag and drop locks up whole OS



  • HI All,
    I have some software in written on creator. In the past it ran great. However I've just update from lubuntu 14.04 to lubuntu 16.04 ( linux ) and now drag and drop operations lock the whole OS. I can drag and drop the first time I open any drag and drop dialogue. But when I re open or open a new drag and drop field and I start to drag and drop after item is drag a couple of pixels my whole OS locks up and the only way to recover is a reboot. I've tried to recompile against this OS ( 16.04 ) but the issue is still there.
    Has anyone seen this before, update OS software cause whole OS to lock up? And can anyone offer any advise please. Thanks in advance :D

    PS eveything else appears to work fine, creator is 3.5.1.

    Should add I've just tested in creator in debug mode, works fine. Use a stand alone build and lock up



  • @tony67
    Never mind that you wrote the code/compiled in Qt Creator: are you saying that the app with d&d only "locks" when you run it from Qt Creator, or does it do same when you run it as standalone executable outside of Qt Creator?

    Similarly, (when run outside Qt Creator) are you saying the "lock" depends on whether you compiled the executable for debug versus release?

    Need to determine whether Qt Creator itself has any relevance, or just the executable you generated.



  • Thanks.
    When I run in Qtcreator in debug mode it runs fine. No lock up. If I run as a standalone it locks the whole OS. I'll try running from Qt in none debug later today. I realise it's a long shot posting but thought someone might come back with a "ahh 16.04 lubuntu has an issue..." or something along those lines.


  • Qt Champions 2017

    Hi
    By standalone, you mean clicking on the ".exe" ?
    It sounds like it picks up some wrong Qt so files.
    do a LDD on exe and look where it loads stuff from.
    If not from the folder of the Qt you used to create the ".exe" its the reason.

    You are supposed to make a deployment folder and run it there. with the right SO files.



  • Thanks that looks like the issue. I'm just using the exe. I'll look into the libs.


  • Qt Champions 2017

    @tony67
    btw I like this place for the deployment folder info
    http://www.tripleboot.org/?p=138
    section "Linux GCC 32-bit and 64-bit compilers:"


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.