Compiling QT 5.10 on Windows Server 2012 R2 and VC 2017



  • Hello,
    I'm trying to compile QT 5.10 (everywhere-source) on Windowser Server 2012 R2 with VC 2017 because I want static linking. I tried to follow these instructiuons : https://doc-snapshots.qt.io/qt5-dev/windows-building.html . I altered the file as such:
    CALL "C:\Program Files (x86)\Microsoft Visual Studio\Shared\14.0\VC\vcvarsall.bat " x86
    SET _ROOT=D:\QT\qt-5.10.0
    but I'm getting errors trying to run this.
    Error in script usage. The correct usage is:
    "C:\Program Files (x86)\Microsoft Visual Studio\Shared\14.0\VC\vcvarsall.bat " [option]

    I've seen a lot of different problems reported with vcvarsall.bat but none of the suggested solutions that I found solved mine. Trying to manually set the paths for example to nmake.exe will only create compile errors when trying to compile qt.
    Is there any documentation on what parameters I need to set for my system ? or is my VC installation buggy ? I was able build apps with the installer version of qt.

    Regards,
    Gerhard



  • The solution that worked for me is to start "Developer Command Prompt for VS2017" (default) followed by running configure.bat in my case with following parameters:

    configure.bat -static -debug -platform win32-msvc -skip qtwebkit -prefix d:\qt

    ... it's still compiling at this moment so not sure yet if it will actually complete successfull yet...

    To me this means that the article : https://doc-snapshots.qt.io/qt5-dev/windows-building.html is not valid for all windows / visual studio versions or an incomplete description.

    Cheers,
    Gerhard


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.