"QtQuick 1.0" vs. "QtQuick 1.1" in Qt 4.7.3 and QtDesktop



  • Hi,

    1. I installed Qt 4.7.3. and created a new QML project.

    2. QtCreator created a qml file in this new project.
      The first line in this file is: "import QtQuick 1.0"

    3. I downloaded (from the git repo), built and installed the "QtDesktop" QML library (= "qt-components")

    4. the file "SplitterRow.qml" of "QtDesktop requires "QtQuick 1.1" in the first line.
      So, "Components.SplitterRow" is not usable in the current Qt distribution!

    What could be the solution?
    Should I update my QtQuick version? How?



  • QtQuick 1.1 is not avail in 4.7.3. It will be avail at next version.



  • That means, a lot of QtDesktop-components are not usable currently!
    What a pity!
    Is there an other SplitterRow (a component like QSplitter for QML) implementation instead of this one from QtDesktop?



  • I suppose that 4.7.4 is not far ... I hopes ... you can use, like mit Qt4.7.4 from git ... it works fine



  • Both 4.7.4 and 4.8 will have QtQuick 1.1. Just use them.



  • Yes, we were not sure about requiring 1.1 but we decided to do it for the Splitters because it significantly improved the code quality. The assumption was that 4.7.4 was just around the corner. I am not sure what is holding it up right now but since Desktop components themselves are still in development I don't really see a big problem. We could create a qt quick 1.0 branch and simply remove the items that require 1.1 if it helps though.



  • Hi,

    In Qt 4.7.3 Qt-Quick is set by default 1.0 for all the platforms excluding the harmattan devices where it is set (and works) the 1.1 version.



  • (In related news, 4.7.4 was tagged on git.)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.