In need of Help - Qtcreator.exe not running



  • Hello, and thank you for taking the time check out my forum post. I am not sure where I am supposed to post this, but thank you nonetheless, and I would be happy to redirect my thread elsewhere. I have tried just about everything, I have no idea why but when I double click my Qtcreator.exe, my cursor shows that something is loading however nothing happens afterward. I have downloaded the 64 bit installer from the website and I have chosen to download version 5.9.2 as well as every option under the tools checkbox. I have tried installing the program to my SSD, and my HDD in hopes that maybe it had to do with my execution path, but no luck. I have been downloading different versions and different tools but there is still nothing happening when I run the .exe. I should also note that the Assistant, Designer, and Linguist programs work however.

    I installed Qt to my E drive, which is
    E:\Qt
    However if I check the location of my Qt community launcher it takes me to the following:
    C:\Users\Zachary\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Qt

    Any help would be greatly appreciated, I am pretty much out of ideas and options. I would be happy to answer any installation/setup questions as well.

    Thankyou



  • Hi, try disabling your antivirus program. Also you can try launching Qt Creator manually, by opening a CMD window and type:
    E:\Qt\Tools\QtCreator\bin\qtcreator.exe



  • Hi Kskoglund, thank you for the quick reply. I have tried disabling windows defender and also tried to launch Manually into the CMD window, and nothing noticeable seems to happen.


  • Qt Champions 2016

    @ZacharyRose

    Hi can you try from CMD with
    qtcreator -noload Welcome -noload QmlDesigner -noload QmlProfiler



  • @mrjj said in In need of Help - Qtcreator.exe not running:

    qtcreator -noload Welcome -noload QmlDesigner -noload QmlProfiler

    Hi MrJJ, thank you for the response. I have tried all three options and no luck. I have noticed that in my task manger Details header, the Qtcreator.exe appears for about 1 second before dissapearing whenever I try to run the program.


  • Qt Champions 2016

    @ZacharyRose
    Ok, this was to test screen driver / openGL support.
    The welcome screen is QML and demands good opengl but it was not that since it made no difference.

    Could try to run this
    "C:\Qt\5.9.1\msvc2015_64\bin\qtdiag.exe"
    (if using mingw, its in that folder instead of the vs2015 one)

    qtdiag.exe > info.txt

    and post here?

    I think you are experiencing something not often seen as you tried multiple installs and still not starting.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What version of Windows are you running ?
    What is your graphic stack ?
    What processor are you using ?



  • @mrjj

    Thanks for the response. I had run the program however a black box appears for about 1 second before closing itself. I can take a screen shot in the few frames that it is there before it goes away:

    0_1508875090140_e9b9f29a-b5ba-4aff-a385-536b7b3adfff-image.png


  • Qt Champions 2016

    @ZacharyRose
    Hi
    You should first open a cmd
    then type
    \fullpath\qtdiag.exe > info.txt

    Then you have the info in the file info.txt




  • Lifetime Qt Champion

    Did you try updating the Graphic Card driver ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.