Debugger hangs on macOS



  • Re: Debugger hangs on Mac OS X...

    this seems still not solved. (Qt 5.9.2)
    and it's really annoying and makes debugging a pain, as this takes 7 minutes (!) each time i open a variable in the variables view during which the debugger is completely blocked.

    debugger log:

    (lldb) script theDumper.fetchVariables({"autoderef":0,"context":"","displaystringlimit":"100","dyntype":1,"expanded":["inspect","return","local","watch","local.this"],"fancy":1,"formats":{},"nativemixed":0,"partialvar":"local.this","passexceptions":0,"qobjectnames":1,"stringcutoff":"10000","token":11,"typeformats":{},"watchers":[]})
    bridgemessage={msg="Searching for type QObjectPrivate across all target modules, this could be very slow"},

    eERROR: Lldb stderr: error: MemoryInspector.o DWARF DW_TAG_array_type DIE at 0x00014d9f has a class/union/struct element type DIE 0x00014dab that is a forward declaration, not a complete definition.
    eTry compiling the source file with -fno-limit-debug-info or disable -gmodule

    i don't know whether the eERROR part refers to the problem (as the poster of the referenced post assumed) but the first block of the message clearly is.

    how can this be solved?



  • I have the same problem. Does anybody have a solution? Running the latest Qt with OSX and Xcode9.1


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.