QtWebEngine won't be compiled



  • Hi there,

    I'm trying to compile Qt5.9.2 with MSVC2017 from source and it won't compile QtWebEngine.

    Every other component like QtCore, QtWidgets, QtQuick etc. compiles without any error.

    The error QtWebEngine throws is the following:

    link /NOLOGO /DYNAMICBASE /NXCOMPAT /DEBUG /DLL /SUBSYSTEM:WINDOWS /VERSION:5.9 /MANIFEST:embed /OUT:..\..\lib\Qt5WebEngineCasd.dll @C:\Users\MIKE~1.KNA\AppData\Local\Temp\nmF02C.tmp
    Library "..\..\lib\Qt5WebEngineCasd.lib" and object "..\..\lib\Qt5WebEngineCasd.exp" was created.
    qtwebengineglobal.obj : error LNK2019: Reference to unresolved external symbol ""void __cdecl QtWebEngineCore::initialize(void)" (?initialize@QtWebEngineCore@@YAXXZ)" in function ""void __cdecl QtWebEngine::initialize(void)" (?initialize@QtWebEngine@@YAXXZ)".
    ..\..\lib\Qt5WebEngineCasd.dll : fatal error LNK1120: 1 unresolved externals
    

    What is wrong and how do I solve this problem?

    Kind regards,
    Mike

    Environment:
    OS: Windows 10 Pro x64
    RAM: 8GB
    Qt: 5.9.2 Opensource Shared
    MSVC2017 v.15.4.0
    Windows 10 SDK (10.0.15063.0)
    ActivePerl 5.24.2.2403 MSWin32 x86-64int 403863
    Python 2.7.14
    Ruby 1.9.3-p551
    depot_tools
    Ninja
    win_flex_bison-2.5.5
    OpenSSL 1.0.2j



  • @Lachrymology
    I don't know for sure under Windows, but QtWebEngine has some additional dependencies you may need, and/or the make process may need some help. See:



  • Hi JNBarchan,

    thank you for the links, but I've searched (nearly) through the entire internet to find everything about this topic.
    To complete the list we should add this link to the list:
    https://chromium.googlesource.com/chromium/src/+/master/docs/windows_build_instructions.md
    and this one:
    http://doc.qt.io/qt-5/windows-requirements.html

    .. but the dependencies aren't the problem, as you can see in the list of my environment above. All dependencies are available and Qt5.9.0 and Qt5.9.1 will build without such an error.

    Maybe I should mention that I'm using this one to build:
    https://download.qt.io/archive/qt/5.9/5.9.2/single/qt-everywhere-opensource-src-5.9.2.zip

    I tried to build with nmake, tonight I will try to build with jom, but IMHO for such an error like LNK2019 another project tool won't solve the problem at all.

    Kind regards,
    Mike



  • @Lachrymology said in QtWebEngine won't be compiled:

    All dependencies are available and Qt5.9.0 and Qt5.9.1 will build without such an error.

    Ah, so you are saying this is only a Qt5.9.2 problem, specifically? You can use the exact same environment/make with 5.9.0 & 5.9.1 and it works? I feel your question might want to make this explicit?

    I'm afraid I'm not the person to solve your issue, I was just trying to be helpful. I suspect the first thing someone else will ask you to verify is that you are absolutely clean after building a different version.



  • Hi JNBarchan,

    I was wrong, 5.9.1 quits with the same error only 5.9.0 compiles successfully. I dont wanted to do ask that counterquestion, but what shall be these major changes in minor build changes that I should be not able to use the same environment for 5.9.X?

    Don't take me wrong, I appreciate your help, but it didn't helped me because I've read these links before posting here. Your reply didn't contain any question I could answer to clear something out. I only have stated the other 5.9.X builds to compare this error - for me this is a appropriate method to limit an error.

    Kind regards,
    Mike



  • Hi all,

    I tried to limit the error much more.
    It doesn't matter if I compile 5.9.2/5.9.1 with the use of nmake or jom.
    Next thing is that it doesn't matter if I compile 5.9.2/5.9.1 as 32bit version or 64bit version.

    Kind regards,
    Mike


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.