Can't compile QT 5.9.1 from source with -sql-odbc option.



  • Hey,

    I'm currently trying to run the configure script with sql-odbc, though i keep on getting errors.

    The command I'm running is

    configure -static -debug-and-release -sql-odbc -xplatform winrt-x64-msvc2017
    

    The error i got is

    ERROR: Feature 'sql-odbc' was enabled, but the pre-condition 'features.datestring && libs.odbc' failed.
    

    Anyone has any idea what is causing this?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Likely not finding the dependency needed. Please add -v to your configure option and you'll get more information about what exactly is causing this failure.



  • I figured out what is going on.

    Windows runtime does not allow for ODBC, Windows store apps do not use ODBC either.
    SQLite seems to be the only option.

    Building for win32-msvc2017 will build fine with sql-odbc.

    Thanks for the help.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.