QML debugging & qmljsdebugger profiling is disabled on RPI with Yocto (poky-pyro)



  • I want to use QML Profiler to collect data, that qmljsdebugger process hosts on target device. I run my application with the following params;
    <app executable> -qmljsdebugger=port:<any available>
    I try to run the profiler to collect data, from within the qtcreator(external)
    The issues I am facing on the target device right now are two; #1, the application does not run in debug mode, and #2, the qmljsdebugger module does not start.
    I believe that if the application runs in debugging mode, the following line should be displayed when the app is run on command-line;
    QML debugging is enabled. Only use this in a safe environment. (does not appear!)
    And if qmljsdebugger module starts, the following line should be displayed when the app runs;
    QML Debugger: Waiting for connection on port <port_number>. (does not appear!)

    Now, to enable debugging mode, I understand that we need to put the following in .pro files of the project;
    CONFIG+=qml_debug
    And to start the qmljsdebugger, we need to give the parameter along with the app executable, as mentioned above.
    I also understand that qmljsdebugger has dependency on two files;
    libqmldbg_tcp.so
    libqmldbg_inspector.so
    They have to be present on the target device in qmltooling folder which normally lives in plugins folder in qt5 lib folder on the system.
    These files were missing on the device. So I tried to bitbake the toolchain and get these files from there. But what I get is not qmltooling folder with the above two files, rather I get qml1tooling folder with one file with different name (libqmldbg_tcp_qtdeclarative.so). I didn't expect it to work and it didn't. Apart from that, I copied lib, bin, include from sysroots to /usr/lib, usr/bin, and /usr/include folders. But nothing seems to be budging anywhere around.
    Any help shall be highly appreciated.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.