Qt 4.3.1 compile for windows XP



  • Hi.

    I created a GUI with Qt 4.3.1 installed on windows 7 home x64.
    Nothing special: 5 windows, pictures, animated gifs, buttons to run external programs (vlc, xnView...), sounds when buttons are clicked.

    I compiled it as "release" and added the .dll files from the "...\Qt\5.9.1\mingw53_32\bin" folder.
    It works on my windows 7.
    There were other .dll files with the same names in the "...Qt\Tools\QtCreator\bin" folder, but they didn't work, so I guess they are the .dll for "debug"...

    My problem is that it is supposed to work on windows XP pro 32x.
    By running the .exe under XP, the following message comes up: "Unable to find CancelIoEx in KERNEL.dll libray".
    (I translated the message, maybe it's not exactly like this)

    I found some threads about this telling to add "-target xp" parameters somewhere, but the beginner I am didn't really understand a lot about it.

    It took me many hours to write the code and it's quite upsetting to be stuck at the very last step :-(

    SOS please help me.

    Thanks in advance!



  • Your Qt version 5.9.1 is too new for XP :-(
    Either Qt 5.6.2 or Qt 5.7.1 works fine for Windows XP.



  • Ok

    I'll download an older version of Qt and try.

    Hope there will be no problems with the code created with a newer version.

    Thanks.



  • I installed Qt 5.6.2, opened and compiled the project. No errors, and It starts under XP.
    Great.

    However there is still something I cant' figure out:

    After compilation, I pasted the folders with the photos, sounds, plugins and other stuff next to the .exe file in the release folder, and placed that same release folder on a USB stick.

    When I run the .exe with the Pc I compiled with, everything is fine.
    When I run it on another PC, no sounds, no photos...???

    To test, I pluged the USB stick back on the PC I compiled with, changed the name of a photo and then ran the .exe file.
    The photo I changed the name did not show up, so I'm sure the program takes the photos on the USB stick, and not those of the Qt output folder.

    What is happening?
    Thanks again.



  • All pictures the are set like this:

    picture1 = new QLabel (this);
    picture1->setPixmap (QPixmap("pictures/picture1.jpg"));
    picture1->move (100, 100);
    

    Maybe something to do with the folder paths...?



  • Hi I also got bitten by that bug (no icons on my toolbar on another PC!). You need to copy more of those plugin .dlls. Try copying all of the files in the imageformats and audio folders...



  • First time I tried, I decided to copy all the plugin folders next to my .exe and sort them later, but it didn't work.
    Did everything again... compilation...dlls...plugins... And now it works. Woooonderful!
    Certainly a wrong handeling of mine.

    The only little problem left is that under XP, the ToolTips screen all black.
    I'm going to try to fix this, or simply kick them out if I don't get it.

    Thank you very much for your help sir!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.