About QtMsgType



  • Now, QtMsgType is defined like this:
    enum QtMsgType { QtDebugMsg, QtWarningMsg, QtCriticalMsg, QtFatalMsg, QtInfoMsg, QtSystemMsg = QtCriticalMsg };

    i think it should be :
    enum QtMsgType { QtDebugMsg, QtInfoMsg, QtWarningMsg, QtCriticalMsg, QtFatalMsg, QtSystemMsg = QtCriticalMsg };



  • Agree with you. Some more points note here.
    These are simple enumerations and defined that way. We should be using these enumerations for any checks/switch statement so that order of these enumerations does not matter. These enumerations work as well. It is very well possible that QtInfoMsg got added later, hence this order. Changing this order may impact backward compatibility as well. We are better off to keep the things the way they are unless there is huge gain for making these changes.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.