Multiple issues with examples



  • Hello,
    I am struggling with right set up for Qt5.9.1 on Fedora 26, probably missing a lib or a module.
    The issues:

    • When running example 'Audiolevels' - completely black window, no error message in application output. Same applys for 'Planets QML'
    • When running 'Hello speak example' : error message 'No text-to-speech plug-ins were found', Also trying to list QTextToSpeech::availableEngines(): <empty>

    I have speech-dispatcher, festival and espeak installed, gstreamer-plugins 1 and 0.10 are installed, pulseaudio installed, qtmultimedia as well, no idea what is missing, since there are basically no error messages. Could anyone help me out with this?
    Thank you.

    EDIT1:
    Workaround for the black screen : run X11 instead of Wayland

    EDIT2:
    Hello speak example: https://bugreports.qt.io/browse/QTBUG-58461
    Audio Visualizer example: Does not produce any sound. - similar to https://bugreports.qt.io/browse/QTBUG-58125


  • Qt Champions 2016

    Hi
    Is your openGL up and running ?
    QML wants it.

    Also, did you install the backend ?
    speech-dispatcher or any other synthesizers that is detected.



  • @mrjj Hi,
    Thank you for your response.

    Yes, OpenGL is up. Could you be more specific about the backend? I admit I am a bit confused about the speech-dispatcher thing... Speech dispatcher is installed, when I use for example:
    $spd-say 'Hello'
    I get the output as expected. Same for espeak, however ( may or may not be important ) when entering festival:
    $festival> SayText "Hello" provides no sound output ( also no error here )

    Mark



  • Aight, first part of the problem solved (partially)... It was Wayland causing the black screen, in a moment I switched to X11, it was okay.
    But still having troubles with the audio. The 'Audio Visualizer' example neither loads the song, nor plays any sound. Also I can't stop it or pause it.


  • Moderators

    @macermak For media like audio you need to install GStreamer libraries.



  • @jsulm Thank you for your response,
    I know, as I mentioned before, I believe I have all of them installed. Both 1 and 0.10.
    I found a bug that describes similiar thing on Windows (no solution): https://bugreports.qt.io/browse/QTBUG-58125?jql=text ~ "audio visualizer"

    PS: Enclosing output of $rpm -qa | grep gstreamer
    [0_1502774628239_output-gstreamer.txt](Uploading 100%)


  • Moderators

    @macermak You can try to start the example with QT_DEBUG_PLUGINS set to 1 to see what exactly happens when plug-ins are loaded



  • @jsulm That is a great advice! At least I can trace it somehow.
    I can see an issue:
    Cannot load library /home/macermak/Qt/5.9.1/gcc_64/plugins/imageformats/libqjp2.so: (libjasper.so.1: cannot open shared object file: No such file or directory)
    QLibraryPrivate::loadPlugin failed on "/home/macermak/Qt/5.9.1/gcc_64/plugins/imageformats/libqjp2.so" : "Cannot load library /home/macermak/Qt/5.9.1/gcc_64/plugins/imageformats/libqjp2.so: (libjasper.so.1: cannot open shared object file: No such file or directory)"

    $rpm -q qt5-qtimageformats
    qt5-qtimageformats-5.7.1-5.fc26.x86_64
    $sudo find / -name libjasper*
    /usr/lib64/libjasper.so
    /usr/lib64/libjasper.so.4
    /usr/lib64/libjasper.so.4.0.0


  • Moderators

    @macermak Well, this is JPEG - not related to audio



  • @jsulm Yes, I agree, but it is the only issue I can see in the debug output. Plus, I don't know how to solve at least this, since there is no libjasper.so.1 in jasper-libs anymore. Any idea?


  • Moderators

    @macermak On Ubuntu you need to install libjasper1 package.



  • @jsulm Yes, but I am on Fedora 26, which is using libjasper.so.4


  • Moderators

    @macermak Could be that it provides an older version of the lib as well, or you could try to hack a bit and create a symbolic link:

    ln -s libjasper.so.1 libjasper.so.4
    

    :-)
    But this will not work if these two versions are not compatible.



  • @jsulm Thanks, this is kinda brilliant, it did satisfied the debug message! Did not solve the problem with the audio visualizer tho. Should I report it as a bug?

    BTW as far as the text to speech example is concerned, I found https://bugreports.qt.io/browse/QTBUG-58461 .. seems like a current problem that is being worked on.

    For future reference, if someone wants to fix this as well, the command is vice versa:
    $ ln -s libjasper.so.4 libjasper.so.1


  • Moderators

    @macermak Yes, symbolic link can be very handy :-)
    You can report it as bug but you should first search there - maybe it is already reported.



  • @jsulm Ye, I found some similar bugs that have already been reported. Lets hope for the fix soon. Thank you for the help anyway.

    Mark.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.