Project .exe won't run outside of QT



  • Hello everyone,
    if I try to run my release .exe of my project outside of QT I just get the "qt the procedure entry point could not be located" error. I already set the correct path to the correct version of the "mingw/bin" folder in the Qt directory. I also tried just copying the correct .dll files to the release folder with the same effect.
    But when i try to start it over the following .bat file it works:

    @
    set PATH=D:\Qt\5.8\mingw53_32\bin;%PATH%
    project.exe
    @
    

    I have "D:\Qt\5.8\mingw53_32\bin;" added in my path variable so I shouldn't need to do this.


  • Qt Champions 2016

    Hi
    You should make a deployment folder for it.
    http://www.tripleboot.org/?p=138

    Note the sub folders.



  • I just fixed it. It seems you still have to move some files into the folder.
    I moved the "libgcc_s_dw2-1.dll" "libstdc++-6.dll" "libwinpthread-1.dll" into my release folder and it works.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.