Fehler beim einrichten der GNU Toolchain



  • Hallo,
    nachdem ich hier gute Hilfe bekommen habe, möchte ich mich nochmal an Euch wenden.
    Ich hänge seit einigen Tagen daran dassich die Toolchan für den Raspberry nicht einrichten kann. Ich folge der Anleitung :
    Cross-compiling Qt Embedded 5.5 for Raspberry Pi 2
    "https://visualgdb.com/tutorials/raspberry/qt/embedded/"
    Hier komme ich bei Step 16 nicht mehr weiter. Ich bekomme die folfenden Messages:

    • list itemRunning configuration tests...
    • list itemThe test for linking against libxcb failed!
    • list itemUse of pkg-config is not enabled, maybe you want to pass -force-pkg-config?
    • list itemYou might need to install dependency packages for libxcb.
    • list itemSee src/plugins/platforms/xcb/README.

    Ich denke da habe ich bei der Installation was falsch genmacht.
    Die Hardware ist
    QT-Host: Windows 10
    Target Maschine: Raspberry 3
    Kann mir da bitte jemand weiterhelfe?
    Vilen Dank.
    Kurt


  • Moderators

    Dieser tutorial is alt und hat Fehler. Ich empfehle https://wiki.qt.io/RaspberryPi2EGLFS, es ist viel besser (aber es ist auf Linux host basiert). Also, nutze the neueste Qt (5.9.1), weil Platform Support ist besser jetzt als in Qt 5.5 Zeiten.



  • Hallo,
    jetzt bin ich ein bisschen weiter gekommen.
    Ich habe die GNU-Toolchain installiert.
    Jetzt sieht es aber so aus, dass ich Probleme habe das KIT zu managen.
    Ich bekomme den Hinweis, dass cmake nicht konfiguriert sei. Da finde ich aber auch nichts dazu.

    (1) Brauche ich das bzw. wo bekomme ich das her?
    (2 )Muß ich das selber machen? und wie?
    Vielleicht hat einer einen Tipp?
    Danke.
    Gruß
    Kurt


  • Moderators

    @K-Str said in Fehler beim einrichten der GNU Toolchain:

    Hallo,
    jetzt bin ich ein bisschen weiter gekommen.
    Ich habe die GNU-Toolchain installiert.
    Jetzt sieht es aber so aus, dass ich Probleme habe das KIT zu managen.
    Ich bekomme den Hinweis, dass cmake nicht konfiguriert sei. Da finde ich aber auch nichts dazu.

    Das sollte auch nur ein Hinweis sein, wenn ich es richtig in Erinnerung habe.

    (1) Brauche ich das bzw. wo bekomme ich das her?
    (2 )Muß ich das selber machen? und wie?

    Versuche es erst einmal so. Wenn du das Kit so schon eingerichtet hast und nur die zusätzliche Meldung kommt, müsste schon alles in Ordnung sein.
    Dies gilt, wenn du nun ein qmake erstellt hast und schon bei dem Cross-Compiler ein make dabei ist.
    Allerdings kenne ich deine Cross-Compile-Chain nicht.

    Ich verwende MihGW-Tool-Chain und schliesse nun von da auf deinen CrossCompiler.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.