Qt errors while building app



  • When I attempt to build my project for android, these errors occurs:

    Warning: QML import could not be resolved in any of the import paths: QtQuick.Extras.Private.CppUtils
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Extras.Private.CppUtils
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.Material.impl
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.impl
    Warning: QML import could not be resolved in any of the import paths: QtQuick.Controls.Universal.impl
    

    These are not just nonsignificant warnings! These are really important problems because Qt creator can't import Qt quick.
    Thus, my application won't have any visual object. How can I solve this error? Also this is .pro file of my project:

    QT += qml quick
    CONFIG += c++11
    SOURCES += main.cpp \
        downloader.cpp \
        filemanager.cpp
    HEADERS += \
        downloader.h \
        filemanager.h
    RESOURCES += qml.qrc
    QT += network
    QT += xml
    QT += gui
    QML_IMPORT_PATH = /home/muhammad/Qt5.9.0/5.9/android_armv7/qml/
    #QML_DESIGNER_IMPORT_PATH =
    DEFINES += QT_DEPRECATED_WARNINGS
    qnx: target.path = /tmp/$${TARGET}/bin
    else: unix:!android: target.path = /opt/$${TARGET}/bin
    !isEmpty(target.path): INSTALLS += target
    DISTFILES += \
        android/AndroidManifest.xml \
        android/gradle/wrapper/gradle-wrapper.jar \
        android/gradlew \
        android/res/values/libs.xml \
        android/build.gradle \
        android/gradle/wrapper/gradle-wrapper.properties \
        android/gradlew.bat \
        android/AndroidManifest.xml \
        android/gradle/wrapper/gradle-wrapper.jar \
        android/gradlew \
        android/res/values/libs.xml \
        android/build.gradle \
        android/gradle/wrapper/gradle-wrapper.properties \
        android/gradlew.bat
    ANDROID_PACKAGE_SOURCE_DIR = $$PWD/android
    

  • Moderators

    @no_ideaw
    are you porting an older app to Qt 5.9?



  • @raven-worx no I wrote it in the latest version of Qt.


  • Moderators

    @no_ideaw
    so where do you have those imports then?
    Are you trying to build an example from somewhere? I am asking because the material design path is out-dated and moved to the quickcontrols2 module.



  • @raven-worx it's not an example. it's my project.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.