[OpenSUSE]"qmake is not a typo you can use"|"Could not start D-Bus"



  • I'm a noob ,and I have a depressing issue after installing Qt5.9.0 on my OpenSUSE Leap 42.2:
    Read the instructions on Qt-Wiki;
    Downloaded the xxx.run file;
    Chmod and executed the file locally;
    Followed the graphical setup;

    Started Qt-Creator and Successfully built and run samples from the Examples;
    (Qt installation seems to be correct )
    ---------------------Everything's Going Well until I Did Stuff Below---------------------------
    I try qmake -version in Terminal and it tells:
    "If 'qmake' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf qmake
    "
    (Problem1: Apparently, my graphical setup didn't add the Qt directory in the Environment )

    Tried adding lines in /etc/profile
    Tried resource /etc/profile in Terminal
    Tried qmake -v in Terminal
    "QMake version 3.1
    Using Qt version 5.9.0 in /opt/Qt5.9.0/5.9/gcc_64/lib
    "
    (It works seemingly)
    ------.------------.-----
    Reboot and Login
    Failed to get a KDE desktop. Instead ,I got a window with the message :
    "Could not start D-Bus. Can you call qdbus-qt5"
    and when I clicked "OK", nothing happened.

    Went into the Terminal by pressing Ctrl-Alt-F1
    Commented out the lines added previously
    Reboot
    And my KDE desktop is back
    (Problem2: Unable to login to my KDE desktop if adding the Qt directory in /etc/profile)

    So What Shall I Do to Work Around it (or them)?
    OR
    Just give up , forget about qmake and Terminal.
    Pledge my eternal loyalty to Qt-Creator?



  • Hi,

    KDE ships its own version of Qt which for sure is a an older version than 5.9. There will always be trouble between the two versions as they try to talk with each other via Dbus, which usually will not work.

    Your best solution will be to change your desktop system, or use the KDE built in Qt.

    -Michael.



  • @m.sue
    Thanks for your attention!
    Yeah! I've noticed that different versions may be the key point, and I've tried to skim through and ( failed to )understand what is written in /usr/bin/startkde.
    Well anyway, it still beats me why "qmake is a command not found" even before I install the latest version of Qt. (the Environment seems not to include the KDE built-in Qt) Or to say, I don't know how to use the KDE built-in Qt without qmake and other sort of things :O
    (I've ever thought about uninstalling the Qt I installed, and to see what would happen if installing Qt-Creator solely. But it would be another story..)


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    That's because qmake is part of the Qt development tools package which is not installed by default.

    When you install Qt with the online installer, it will be a self-contained development environment that won't mess with your system.

    The better and safe way to call qmake on the command line is to use the full path to the executable. Doing so, you are sure to use the version that you want.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.