Important: Please read the Qt Code of Conduct -

Qt Creator 4.3.0 doesn't start

  • Hi! I can't start Qt Creator 4.3.0. If I try to run the program nothing happens.
    When I start Qt Creator in the task manager the process "VerFault.exe" appears and immediately disappears.

    Qt's configuration of components:
    Qt 5.9:
    -MinGW 5.3.0 32 bit
    -UWP armv7 (MSVC2017)
    -UWP x65 (MSVC2017)
    -UWP x86 (MSVC2017)
    -Qt Charts, -Qt Data Visualization, -Qt Purchasing, -Qt Virtual Keyboard, -Qt WebEngine, -Qt Network Auth (TP), -Qt Remove Object (TP), -Qt Speech (TP), -Qt Script (Deprecated);
    -Qt Creator 4.3.0
    -Qt Creator 4.3.0 CDB Debugger
    -MinGW 5.3.0.

    My system:
    -Windows 6.1.7601
    -Mobiliti Radion HR 5430.

    The reinstallation didn't help. The launch without "Welcome" also did not help.
    I maked a log using procmon. I started the program as administrator then the processes were started:
    -processes of Avast

    Disabling antivirus didn't help. The introduction of qtcreator.exe in the exclusion of antivirus didn't help.

    [Moved to Tools ~kshegunov]

  • Qt Champions 2017

    Could you try running it from the command line and possibly inspect what is output there. There might be a hit about a plugin not being loaded, or a library that's missing or something like this. On a related note is it possible you have some Qt library's version in your PATH variable which may interfere with the startup?

  • @kshegunov
    When I call the executable file (...\Qt\Tools\QtCreator\bin\qtcreator.exe) nothing is displayed on the command line and I can immediately enter a new command. I don't have Qt in my PATH variable.

  • Qt Champions 2017

    I'm sorry I don't know. This is the first I hear of such a problem. Usually if it's a crash there'd be at least some kind of message or dialog to indicate it, and I'd expect at least some output on the command line. Maybe someone else will come up with another suggestion.

  • @Sergey_Storm Hi, also you can try setting the environment variable QT_OPENGL before launching QtCreator, like this:

    C:\> set QT_OPENGL=software
    C:\> C:\Qt\Tools\QtCreator\bin\qtcreator.exe

  • @hskoglund
    The command that you had proposed caused the system error and the offer to send the report to Windows.
    I could not reproduce this by re-calling only the executable file or all commands.

  • @kshegunov @hskoglund
    Thanks for trying to help. I started using a different operating system. The Qt Creator launches and works.

Log in to reply