Assistance to diagnose crashes in Qt 5.9.0 default web examples



  • Recently I migrated from Ubuntu 14.04 (32bit) to Ubuntu 16.04 (64bit). My earlier limited experimenting with Qt was on 32bit and with this new setup I installed Qt 5.9.0 via online installer.

    I intend to develop a hybrid web application and so started in Qt Creator (Community) by testing a couple of examples from Qt (unchanged).

    contentmanipulator
    markdowneditor

    Each example launches but in each case the launched window soon crashes with segmentation fault reported.

    I can inspect build by running ..

    QT_DEBUG_PLUGINS=1 ./contentmanipulation

    and at the point of crash I see this in terminal ...

    loaded library "/opt/Qt/5.9/gcc_64/plugins/iconengines/libqsvgicon.so"
    Segmentation fault (core dumped)

    ...

    Running the second example ..
    QT_DEBUG_PLUGINS=1 ./markdowneditor

    markdowneditor: ../../nouveau/pushbuf.c:727: nouveau_pushbuf_data: Assertion `kref' failed.
    Aborted (core dumped)

    That path looks rather odd so I searched and did not find it anywhere in my file system.

    sudo updatedb
    sudo locate /nouveau/pushbuf.c

    ...

    For good measure I tried building a third web example with debugging unselected.

    I built demobrowser.

    A window was launched as expected and I could browse tabs.
    However the app soon crashed.

    7f8ec2488000-7f8ec2489000 rw-p 00000000 00:00 0
    7fffc57ce000-7fffc57ee000 rwxp 00000000 00:00 0 [stack]
    7fffc57ee000-7fffc57ef000 rw-p 00000000 00:00 0
    7fffc57f7000-7fffc57f9000 r--p 00000000 00:00 0 [vvar]
    7fffc57f9000-7fffc57fb000 r-xp 00000000 00:00 0 [vdso]
    ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0 [vsyscall]
    The program has unexpectedly finished.

    Again I tried running this in terminal ...

    QT_DEBUG_PLUGINS=1 ./demobrowser

    and the app launches but soon crashes.

    This is the tail of output to terminal:

    7fd47407a000-7fd47407c000 rw-s 00000000 08:12 2635975 /home/<user>/.local/share/Qt/demobrowser/QtWebEngine/Default/GPUCache/data_3
    7fd47407c000-7fd47407e000 rw-s 00000000 08:12 2635974 /home/<user>/.local/share/Qt/demobrowser/QtWebEngine/Default/GPUCache/data_2
    7fd47407e000-7fd474080000 rw-s 00000000 08:12 2635973 /home/<user>/.local/share/Qt/demobrowser/QtWebEngine/Default/GPUCache/dAborted (core dumped)

    ...

    Trying again the app crashed and this was the tail of output ...

    loaded library "/opt/Qt/5.9/gcc_64/plugins/iconengines/libqsvgicon.so"
    Xlib: sequence lost (0x10273 > 0x276) in reply type 0x0!
    Xlib: sequence lost (0x10294 > 0x297) in reply type 0x0!
    Segmentation fault (core dumped)

    ...

    Crash appears on several apps to occur at this point ..

    loaded library "/opt/Qt/5.9/gcc_64/plugins/iconengines/libqsvgicon.so"

    ...

    Can you recommend a structured debugging process for tracking down cause(s) of these crashes?


  • Moderators

    @eureka said in Assistance to diagnose crashes in Qt 5.9.0 default web examples:

    nouveau

    this is the open source driver for NVidia graphics cards.
    Can you try a simple Qt widget application? Is it crashing?
    You could try to install NVidia driver (Ubuntu can do it for you) and see whether it helps.



  • @jsulm
    Your diagnosis was correct. Thanks.

    To summarise my workflow in case other Ubuntu developers have this problem. I'm developing on an old Dell laptop. I read advice here ..

    http://www.webupd8.org/2016/06/how-to-install-latest-nvidia-drivers-in.html

    I could narrow down search by running this command ..

    apt-cache search nvidia | grep nvidia-

    In Ubuntu I launched System Settings > Software & Updates >

    Additional Drivers

    Driver Installed version ..

    NVIDIA Corporation: [G86M 8400M GS]
    this device is using an alternative driver

    There are three options and I had the third driver selected ..

    Using XOrg server - Nouveau display driver from xserver-org-video-nouveau (open source)

    I unticked this option and selected another option ...

    Using NVIDIA binary driver - version 340.102 from nvidia-340 (proprietary, tested)
    ...

    After rebooting and then running demobrowser again I experience no crashes.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.