Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct
Qt 5.1.1 LGPL version compliance
I understand that the current Qt version (5.9) may be used under the LGPLv3 terms.
However, I need to use an older version of Qt (5.1) for specific reasons. As far as I can tell, this may be used under the LGPL v2.1 terms ( http://qt.apidoc.info/5.1.1/qtdoc-online/licensing.html ).
Is this correct? Does anyone have any experience in this area?
Thanks & regards.
LGPLv3 is more restrictive as LGPLv2.1. So if you can comply with the latter you should be good...
To be sure check if you can fullfill all the requirements of LGPLv2.1.
Sorry Eddy - to clarify - can Qt 5.1 still be used under the terms and conditions of LGPL 2.1? (even though newer versions require LGPL 3.0 adherence).
@Qwerty123 See here http://qt.apidoc.info/5.1.1/qtdoc-online/licensing.html
Also in Qt source code files you will find a header mentioning the licenses.
Eddy last edited by Eddy
Qwerty123 used that link in his first thread. ;-)
If you use a code version licensed under LGPLv2.1 it still remains under LGPLv2.1 now. (= Qt5.1)
That work state of Qt has it's freedom and restrictions defined then. The link you are referring to is still in order, otherwise it wouldn't be there anymore.
New modules of Qt are under GPLv3.0 now, but some modules are also GPLv2.
As you can see in the licensing comparison table
So if you need the new goodies, you have to comply with GPLv3.0.
Out of curiosity, what parts of Qt are you needing?
@Eddy But then I don't understand the question: Qt 5.1 was released under LGPL 2.1, so LGPL 2.1 applies. Or do I miss something?
I understand his question as " because Qt 5.9 is now under GPLv3.0, does that mean that Qt5.1 is not under LGPLv2.1 anymore ?"
Qt 5.1 was released under LGPL 2.1, so LGPL 2.1 applies.
is the correct answer
@Eddy Much appreciated - makes sense, was just seeking clarification. Intending to use Qt5Core, Qt5GUI, Qt5Multimedia, Qt5Network and Qt5Widgets.