GUI failed on lauching of QtCreator



  • Hello,

    I have a problem when I launch Qt creator on Ubuntu 16.04. Every time I tried to launch it (from the terminal), the application starts (I can see the processus via the system monitor) but the gui does not. I've installed Qtcreator from the .run provided by the official website. I also tried to install it directly from apt (even if the version's older) but it still does not work. I didn't see any similar problem so I would like to know what you think :)
    My config:
    Ubuntu 16.04 LTS 64 bit
    CPU: Intel Core i7-3720QM 2.6 GHz
    GPU: Gallium 0.4
    8 Go RAM

    Thank you !


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What exact error are you getting ?
    What is your goal ?



  • This is the problem: I don't have any error message but I just can't use Qt Creator because the GUI of the application doesn't start !



  • @ben-oit You can try to mv the creator's config/cache files:
    ~/.config/QtProject/
    ~/.cache/QtProject/QtCreator

    Maybe something in there can not be digested by the creator anymore. Worst case: your preferences are gone but no project will be touched. (Unless you did something really weird, like storing projects in there)



  • Thanks a lot... Actually, I've installed QtCreator a week ago and it worked perfectly until valgrind crashed . So I tried to uninstall/reinstall QtCreator but I always had this problem. I removed the QtProject config files and it finally works...

    Thank you ! :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.