[Dudas] Qt 5.9 LTS y Qbs



  • Que tal,

    Utilizo Qt para proyecto personales, por lo tanto no tengo problemas al actualizarlo en cuando salen nuevas versiones, en este caso actualice a Qt 5.9 por que es una version LTS.
    ¿Es recomendable utilizar (para proyectos personales) la version mas reciente?
    ¿He visto posts de gente que sigue utilizando Qt 4 :s?

    Hace algun tiempo vi una presentación del nuevo (creo yo) build system Qbs, que viene a sustituir qmake, no recuerdo de memoria las ventajas que tiene sobre qmake.
    ¿Los proyectos hechos con versiones anteriores de Qt (qmake) se pueden "actualizar" a que utilicen Qbs sin problemas o los tendre que empezar desde 0 utilizando Qbs desde el principio?

    Saludos



  • Algo que recién aprendí:

    cpp.dynamicLibraries: "pthread"
    cpp.cLanguageVersion: "c11"
    

    Con la primer linea se agrega la librería pthread, con la segunda la aplicación se compila con el estandard c11. Ambos van dentro de la sección de la aplicación.

    import qbs
    
    Project {
        minimumQbsVersion: "1.7.1"
    
        CppApplication {
            consoleApplication: true
            files: "main.c"
            cpp.dynamicLibraries: "pthread"
            cpp.cLanguageVersion: "c11"
    
            Group {     // Properties for the produced executable
                fileTagsFilter: product.type
                qbs.install: true
            }
        }
    }
    

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.