Physical device on N950 + Trick to manage the terminal on N950 device



  • Hi to all,

    I need a confirmation. As I know, the N950 is a device that should be useful to develop software for N9. One of the advantage for the developers is that it has the physical keyboard so it is simple managing the applications from the terminal.

    I am experiencing difficulties using the physical keyboard - on the terminal and not only - because I have found the following issues:

    • Caps lock keys can't be used becausethe SHIFT key has no effect.
    • BACKSPACE key don't work so it is impossible to delete some characters
    • FnKeys e.g. numbers and special characters are not active using the Fn arrow key. The secondary key is active only pressing the key for about three seconds. Using this methos it is very slow to write numbers (i.e. a long ip address :) )
    • CTRL+7 Deletes the entire line
    • CTRL Key don't work at all, only the CTRL key on the bottom of the screen works.

    I see doing some tests that the following CTRL+Key works in a similar way as a VT100 terminal:

    • ^D = Exit from terminal
    • ^L = Clear screen
    • ^M = Enter
    • ^B = Left Arrow = Cursor left
    • ^C = Break
    • ^A = Home of the current line
    • ^K = Delete character to the right of the cursor
    • ^H = Backspace
    • ^N = Scroll down in the command history (same as DownArrow)
    • ^P = Scroll up in the command history (same ar UpArrow)
    • ^@ = [?] character instead of the same [?] key at the right of the space bar.

    No ideas for special characters and symbols i.e. { } [ ] \ etc.

    Is there somewhere a terminal character map or - best - the mode to change the terminal settings ?

    A trick to manage the terminal in a decent way in five steps
    (If you have a wifi connection)

    Connect the N950 device to the same local network of a PC.

    Launch on the N950 the SDK Connection command and press WLAN button. You see the device IP address and the password. The device has activated the ssh server and the password is the temporary password of the developer user

    Open a shell terminal on the PC. If you are working with windows you should install the ssh protocol, not difficult and probably it is already working.

    Supposing that the N950 IP address is 192.168.1.195 (use your device IP) on the terminal session of the PC launch the following command

    @
    $>ssh developer@192.168.1.195
    @

    When the system prompts for a password insert those 6 character password you see on the SDK Connection window on the device (DON'T close this application because the ssh access with this user/password is still alive only when the app is running)

    Now you can work to the device terminal from your PC (including copy and paste, save screen output etc.). From here you can launch your applications that you can see running on the device itself.

    Enjoy :)



  • For me "SDK Connection" application does not start when I tap on that Icon. I was working, and after reboot it dose not work anymore. Any idea what might be the problem..



  • I downloaded the flasher and reflashed the device with the latest versions. Standard flasher was not working (as noted in the documentation ) so I reflashed with the quick flash (the alternative) and all works fine. I know that there are issues to anage usb and reflashing with windows, best to use Mac or Linux



  • I have re-flashed my device with latest version. But I still have this problem. It was working, but after a reboot it stopped working.

    How can I start this application from Terminal?

    Worst case I will re-flash my device.



  • Please can you explain exactly the steps ? After reflashing I think that you should reinstalla the SDK connection and other applications that are downloaded from the network.



  • Ok got it work with below command

    From Terminal.."This Post Helped Me":http://forum.meego.com/showthread.php?t=3837

    @
    $ cd /usr/lib/sdk-connectivity-tool/bin/
    $ ./mad-withhome.sh ./sdk-connectivity-tool
    @



  • And for installing N950 RNIDIS driver, below post helped.

    http://forum.meego.com/showthread.php?t=3848

    I am able to run my app on the hardware device now...



  • Very well. The concluision is that after reflashing some development applicaitons need to be installed / reinstalled. This is what happens to me.

    Did you tried to connect the terminal via ssh from the pc ?



  • nop.. I have not tried.. I use USB option in SDK connect tool.. ssh works with USB option also?? I will try it out..

    I am new to Unix/Linux world.. so it takes sometime for me to learn all these things...



  • Ok.. I can very well do ssh from my pc.. I can browser the file system :)

    [quote author="Alicemirror" date="1311755919"]Very well. The concluision is that after reflashing some development applicaitons need to be installed / reinstalled. This is what happens to me.

    Did you tried to connect the terminal via ssh from the pc ?
    [/quote]

    What applications are supposed to be installed, and where do you find them..



  • As a matter of fact, the usb connection is a cable network connection. It should work at all, but I think that the PC side of the usb-network connection works only with Qt-Creator wile the wifi connection is standard and work for sure.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.