QWebEngineView with proxy on linux



  • Hi,

    I am using QWebEngineView in my application. On launching the application, the application connects to the server and loads the view using QWebEngineView.

    In normal scenario, application is working fine on both windows and Linux.
    I want to use proxy server to connect to the server. To force my application and to ensure that it is using proxy server, i am blocking my machine's IP through firewall.

    Now what happens in case of proxy server is that on windows, it picks the proxy setting of IE and connects to the server.
    On Linux, i am doing the proxy setting using GNOME. However, on Linux, it is not picking the proxy setting from GNOME and thus, not able to connect to the server.

    So, please tell me what is the correct way of using system proxy settings on Linux in QWebEngineView?

    On QT documentation, it is mentioned that on Linux, proxy settings are automatically picked from GNOME/KDE but it is not happening in my case.

    What am i doing wrong and how can i do it?

    Thanks in advance.


Log in to reply