Qt5.7 configure qith zlib error- Qt requires a c++11 compiler and yours does not seem to have that



  • Hello, I am trying to compile qt with -zlib (Qt5.7). I am using the Visual Studio cmd and executing the command:

    .\..\Qt\5.7\Src\qtbase> configure -qt-zlib
    

    The error I get is that: Qt requires a c++11 compiler and yours does not seem to have that
    I am using Visual Studio 2013 and Qt 5.7.
    Could you please help me? How can I solve this error?



  • Hi,

    I am not sure whether this will change anything, but I

    • call configure in the parent directory of qtbase
    • do not use this option at all, as on WINDOWS it is probably used automatically

    -Michael.



  • @m-sue Thank you for your answer. I did call configure on the parent directory, but the error I get there is that Perl is not found in PATH. Although, my PATH environmental variable includes the path of Perl.



  • Hi,

    then maybe the perl version is wrong, or more probably you typed the path wrong. You should be able to starrt perl.exe from the command line. Please try.

    It is important to get this fixed before you continue with configure.

    And sooner or later you will want to add the sub-directory "gnuwin32\bin" to your PATH as well.

    -Michael.



  • @maria_ts Looks strange because Qt is supported with VS 2013. Otherwise I would have thought that the compiler is too old. If it's possible for you to use VS 2015 you can try that. I don't have any VS at hand so I can't say if there are any configuration options in VS which enable or disable compiler features or if they affect Qt configuration at all. But because you trying to configure Qt in command line you can check http://doc.qt.io/qt-5/configure-options.html for Compiler Options section and use the proper options for your platform/compiler, i.e. 32 or 64 and msvc2013. Read also http://doc.qt.io/qt-5/windows-building.html if you haven't done it yet.



  • @Eeli-K Thank you for your answer. I have included the correct paths in PATH environmental variable, and now I am trying to configure QT from Source to find the error. Running the following command

    configure -developer-build -opensource -confirm-license -mp -nomake examples -nomake tests -debug-and-release -c++11 -no-warnings-are-errors -platform win32-msvc2012
    

    I get again the same error about c++11. I have also tried VS2015 and it seems to have the same problem.


  • Moderators

    @maria_ts said in Qt5.7 configure qith zlib error- Qt requires a c++11 compiler and yours does not seem to have that:

    win32-msvc2012

    not sure this is correct.

    Also try to add -v parameter to configure and check what exactly happens during configure execution.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.