Qt Creator letter "i" problem (Not Turkish Keboard)



  • Re: Qt Creator 5.8 - (i) letter not writting
    I've some bad news. I'm using also a Turkish system but not with Turkish keyboard. My keyboard is a classic US keyboard.. But I can't write the letter "I' or "i" in Qt creator.

    System: Korora 25 Gurgle
    Qt Creator: Qt Creator 4.2.2
    Qt Version: Qt 5.8.0



  • Ok. Sorry. I've fixed it from a solution in bug report.

    this is Issue report link: https://bugreports.qt.io/browse/QTBUG-58413

    This is solution:
    " @Tolga Berber's solution
    You can modify the desktop file which is located at [Home Path]/.local/share/applications/DigiaQt-qtcreator-community.desktop to solve problem with qt creator. You have to modify the Exec directive as follows:

    Exec=env LANG=en_US.UTF-8 [Qt Path]/Tools/QtCreator/bin/qtcreator

    Moreover, you have to update the run profiles of your applications in qt creator to make your applications does not affected by this issue. You can add LANG environment variable to your Qt kit by using Tools>Options>Build & Run>Kits settings. Select your kit/kits and add following line to the Environment property:

    LANG=en_US-UTF-8

    After this operation you need to erase all the .pro.user files from your project folders to apply the changes to your existing projects.
    "


Log in to reply