Creating a new project in WMVC 2015



  • Hi,
    I'm new to the forum and new to Qt, so if I have got the wrong place to post this question, or it is an old one that I just can't find, please just let me know where I should be looking/posting.

    A few weeks ago I installed QT on my windows 10 PC and got it to create an empty GUI project. It all worked fine and I could build and run and get an empty window - so far so good.

    Today I tried to create a new project and I find that the wizard seems to fail.
    In Microsoft Visual Studio 2015, I select:
    File/New/Project
    Then I highlight the template:
    Templates/Visual C++/Qt
    The I click on the Template called:
    Qt GUI Application
    In the top right of the New Project window I get a message that says "This Wizard generates a Qt GUI application project."
    I keep the default Name, Location, Solution name (in this case it is calling the project QtGuiApplication2 since the one I created a few weeks ago was, yes you guessed it, QtGuiApplication1).
    I click on OK, the New Project window vanishes and almost immediately reappears. I do notice that I very briefly get the message "Creating project "QtGuiApplication" in the purple bar at the bottom of the screen between pressing OK and the New Project window coming back again. No project has been created and no wizard appears.
    If I try to create a normal Win32 project then I get the normal wizard come up for creating the project. If I select Qt Console Application instead of Qt GUI Application then I also get the project creation wizard OK. The problem seems to be just in getting the wizards to run for the other QT templates.

    So, have I missed something that I did a few weeks ago? Has a Microsoft update nuked my installation already or what?

    Heather


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What version of the Qt plugin did you install in Visual Studio ?

    As an alternative to continue learning Qt, you can also try Qt Creator..



  • Hi, Thanks for the welcome and thanks for getting back to me on this.

    The file I used was, I think,
    qt-vs-addin-msvc2015-2.0.0-beta.vsix
    I am not sure how to get visual studio to tell me the version of the plug in.
    I have tried setting the Qt Options to default to my installs of both Qt 5.7 and 5.8 but that didn't seem to make any difference.

    I have been playing about in the application I managed to create a few weeks ago so I am continuing to have fun with Qt - but would be very nice to fix this so that I can go on and actually make some apps.
    Heather


  • Lifetime Qt Champion

    One thing you can do in between, is to create your project with Qt Creator and then import it in Visual Studio.

    From a quick look you can get a more recent version here.



  • Hi Again,
    New version appeared to install fine but I now have 2 sets of the QT templates. Sadly both of the QtGuiApplication templates do the same thing as before (i.e nothing :-))
    I'll give the Qt Creator a go.

    Heather


Log in to reply