Error while building/deploying project Qt_Application (kit: Desktop Qt 5.8.0 MSVC2015_64bit) When executing step "qmake"



  • I am getting the following error when pressing the green run button: Error while building/deploying project Qt_Application (kit: Desktop Qt 5.8.0 MSVC2015_64bit) When executing step "qmake".

    I saw another thread on this error in these forums but the individual was using GNU Linux, I am running Windows 10. Those suggestions did not work for me. I downloaded and installed the Qt 5.8 for 64-bit. I have VS 2015 and tried installing Mingw. I still get the error.



  • So, in my "Manage Kits" Options there is a red exclamation by my Qt 5.8.0 64-bit install. I notice that next to compiler for both C and C++ there is a grayed-out box that says "<No compiler>. Isn't this stuff supposed to be done in the install? I have both VS 2015 (the one which is compatible with my build) and Mingw.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you install the C++ components when installing VS ? It's not selected by default.



  • @SGaist Thanks for the reply and suggestion. I just figured out my issue. Basically, I am an idiot. I didn't have VS 2015, I had Visual C++ 2015. I signed-up at MS and installed VS 2015 and it runs now.


  • Lifetime Qt Champion

    Glad you could make it work !

    Since you can build now, please mark the thread as solved using the "Topic Tools" button so that other forum users may now a solution has been found :)


Log in to reply