Important: Please read the Qt Code of Conduct -

Crosscompile Raspi3 buttons faulty

  • Hey there,

    i want to cross compile from Ubuntu 16.04 to raspi3.
    i am looking for this tutorial:
    after i tried the example:
    cd qtbase/examples/opengl/qopenglwidget
    scp qopenglwidget pi@raspberrypi.local:/home/pi

    the interesting thing is, that i can see the rotating hologram. (so i think
    but there is no text in the buttons or tabs. mybe i can later give you an screenshot, i necessary?!

    please. need some help.

  • saw following error: "QFontDatabase: Cannot find font directory /usr/local/qt5pi/lib/fonts."
    Any ideas?

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Do you have any font in that folder ?

  • hey,
    thanks for answering.
    i copied the fonts into this folder, but there was no change.
    i dont know how, but maybe i forgot to rsync the qt5pi directory.
    now it works.

  • Lifetime Qt Champion

    Great !

    Since you have it working now, please mark the thread as solved using the "Topic Tools" button so that other forum users may know a solution has been found :)

  • ok. the problem is back...
    the issue was that i took another RPI 3 and i installed qtcreator. i forgot to rsync the qt5pi folder.
    after the rsync i got the same problem... so i think it took the libs from the native qt

  • ok. problem solved.

    i had to set the variables in ~/.bashrc with nano e.g.:
    sudo nano ~/.bashrc

    export QT_QPA_FONTDIR=/usr/share/fonts/truetype

    after closing nano in terminal:
    source ~/.bashrc

Log in to reply