From 5.9 Alpha to 5.9 Beta 1 I can no longer start my app



  • Hi guys,

    After upgrading from 5.9 Alpha to 5.9 Beta I can no execute my project. I allways get:

    • "ASSERT failure in QList<T>::at: "index out of range", file c:\Users\qt\work\install\include/QtCore/qlist.h, line 541"****

    Thats in a few ways really strange because there is now path c:\Users\qt\work\install on my machine. I use the regular c:/qt path. In addition if I start the app in debug mode it works like allways. Swtichting back to 5.8 worked for me now.

    I also create a new blank Qt+qml app. No problem here. Then I commented everything out in my project that is not the same as the new blank app, I still get the same error. Im lost, send help!



  • @QKelteseth If it's working debug but not in release you probably have a pointer that is bad somewhere. That is the typical debug vs release issue. In debug pointers are protected (usually padded with 0s) and in release when you overstep that pointer it isn't padded with 0s so instead of a null you would get some random value. If you turned that random into an int to index a QList, it would go out of range in release but work (most likely) in debug.

    Another idea is that you are mixing Qt libraries. Which sounds possible since you mentioned you don't remember installing to c:/users/qt/work.

    Also, do you know at what point in your code the QList is accessed? If you could share that part of your code we may be able to see the problem.

    And finally, did you make sure everything was clean when you built with 5.9b? So you weren't mixing objects built with 5.9a?



  • @ambershark Thanks for the help I will look into it!



  • @ambershark The problem was that like you said some files used probaply the old alpha version. After reinstalling qt 5.9b it worked. Thanks!

    /Case closed


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.