QT 5.8.0 install on Jetson TK1



  • I have read through multiple forums including QT but I'm not able to get past my initial issues to install 5.8.0 on Jetson TK1. Hopefully someone can point my silly mistake as I have already spent 3 days trying to figure it out!

    I have tried to run the *.run with following issues:

    1. Got the qt-unified-linux-x64-online.run using wget command
    2. ran chmod u+x qt-unified-linux-x64-online.run to update it to execute
    3. when i try to run ./qt-unified-linux-x64-online.run i get "-bash: ./qt-opensource-linux-x64-5.8.0.run: cannot execute binary file: Exec format error"
    4. when i run sudo ./qt-unified-linux-x64-online.run i get the following error:
      ./qt-opensource-linux-x64-5.8.0.run: 1: ./qt-opensource-linux-x64-5.8.0.run: ELF: not found
      ./qt-opensource-linux-x64-5.8.0.run: 2: ./qt-opensource-linux-x64-5.8.0.run: cannot open ?: No such file
      ./qt-opensource-linux-x64-5.8.0.run: 2: ./qt-opensource-linux-x64-5.8.0.run: I
      : not found
      ./qt-opensource-linux-x64-5.8.0.run: 3: ./qt-opensource-linux-x64-5.8.0.run: Syntax error: "(" unexpected
    5. The file is owned by user ubuntu

    So, with no luck, I thought installing using code might work:

    1. I downloaded qt-everywhere-opensource-src-5.8.0.tar.xz file
    2. extracted the file
    3. created folder /opt/qt-5.8.0, symlinked /opt/qt5/
    4. Copied extracted files into /opt/qt5
    5. in /opt/qt5/ ran sudo ./configure -prefix $PWD/qtbase -opensource -nomake tests and it errors out saying:
      + cd qtbase
      + /opt/qt-5.8.0/qtbase/configure -top-level -prefix /opt/qt5/qtbase -opensource -nomake tests

    This is the Qt Open Source Edition.

    You are licensed to use this software under the terms of
    the GNU Lesser General Public License (LGPL) version 3.
    You are also licensed to use this software under the terms of
    the GNU General Public License (GPL) version 2.

    Type 'L' to view the GNU Lesser General Public License version 3.
    Type 'G' to view the GNU General Public License version 2.
    Type 'yes' to accept this license offer.
    Type 'no' to decline this license offer.

    Do you accept the terms of either license? y

    Creating qmake...
    .Done.

    ERROR: Unknown command line option '-prefix'.

    1. only sudo ./configure works but sudo make after that never completes, It ran for 2 days before i decide to kill it.

    I checked and made sure Jetson TK1 is 64 bit architecture, here are some results of some commands

    ubuntu@tegra-ubuntu:~$ uname -a
    Linux tegra-ubuntu 3.10.96-tegra #1 SMP PREEMPT Wed Nov 9 19:42:57 PST 2016 aarch64 aarch64 aarch64 GNU/Linux

    Any direction is much appreciated.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    The Qt pre-built packages are build for x86/x86_64 not ARM hence the error you got.

    As for your build attempt, why are you putting things in /opt ? Since you have to build Qt by hand, just put it in your user home folder so there's no need to fiddle with sudo uselessly until you install.

    You should also rather use an out of source build. That way if something goes wrong or you want to try a different set of configuration option you can easily start from a new folder or nuke the current build. This also avoids to have to clean the sources every time you have to re-run configure.



  • Hello @SGaist

    Thank you for the response!

    I was trying several different things and followed some instructions where they were indicating to install in /opt.

    I have tried your suggestion of extracting it in the home directory and when i run configure I get exactly the same result:

    ubuntu@tegra-ubuntu:~/qt5$ ./configure -prefix $PWD/qtbase -opensource -nomake tests

    • cd qtbase
    • /home/ubuntu/qt5/qtbase/configure -top-level -prefix /home/ubuntu/qt5/qtbase -opensource -nomake tests

    This is the Qt Open Source Edition.

    You are licensed to use this software under the terms of
    the GNU Lesser General Public License (LGPL) version 3.
    You are also licensed to use this software under the terms of
    the GNU General Public License (GPL) version 2.

    Type 'L' to view the GNU Lesser General Public License version 3.
    Type 'G' to view the GNU General Public License version 2.
    Type 'yes' to accept this license offer.
    Type 'no' to decline this license offer.

    Do you accept the terms of either license? y

    Creating qmake...
    ........................................................................................Done.
    Info: creating stash file /home/ubuntu/qt5/.qmake.stash
    Info: creating super cache file /home/ubuntu/qt5/.qmake.super

    ERROR: Unknown command line option '-prefix'.


  • Lifetime Qt Champion

    There's something fishy going on. The -prefix option is part of configure since a very long time.

    Maybe a silly question but are you sure you are using the - the minus char ? Depending on your keyboard it might be a similar yet a different character (thinking utf-8)



  • That was my though too and I tried with single and double '-' with no luck!

    However, I followed the instructions here (http://doc.qt.io/qt-5/configure-options.html) and was able to install QT successfully, summary of steps is below. I have no explanation as to why this worked!

    export QT_SELECT=qt5

    1. wget http://download.qt.io/official_releases/qt/5.8/5.8.0/single/qt-everywhere-opensource-src-5.8.0.tar.gz
    2. tar -xv qt-everywhere-opensource-src-5.8.0.tar.gz
    3. mv qt-everywhere-opensource-src-5.8.0 qt-source
    4. mkdir qt-build
    5. mkdir /opt/qt5
    6. cd qt-build
    7. ~/qt-source/configure -prefix /opt/qt5
    8. qmake
    9. make
    10. make install


  • Re: QT 5.8.0 install on Jetson TK1

    Hi all,

    Something similar tripped me up with Qt 5.9.1, but I was able to resolve it. For me the culprit was failing to copy all the "hidden" dot files, e.g.:

    ./qtbase/config.tests/.qmake.conf
    ./qtbase/tests/auto/tools/qmake/testdata/export_across_file_boundaries/.qmake.cache
    ./qtbase/.tag
    ./qtbase/.QT-ENTERPRISE-LICENSE-AGREEMENT
    ./qtbase/.QT-PROFESSIONAL-LICENSE-AGREEMENT
    ./qtbase/.qmake.conf
    ./qtbase/.release-timestamp
    ./qtbase/src/plugins/sqldrivers/.qmake.conf
    ./qtbase/.QT-FOR-DEVICE-CREATION-LICENSE-AGREEMENT
    ./qtbase/.QT-FOR-APPLICATION-DEVELOPMENT-LICENSE-AGREEMENT
    ./qtbase/.QT-FOR-AUTOMOTIVE-LICENSE-AGREEMENT
    ./qtbase/.QT-INDIE-LICENSE-AGREEMENT
    

    For whatever reason, when these files are missing, the 'configure' tool fails to interpret any options passed to it, even though it does build qmake. The result were errors like this: ERROR: Unknown command line option '-prefix'.

    Hope this helps someone.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Can you explain the steps you did when the configuration/build failed ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.