Important: Please read the Qt Code of Conduct -

QtCreator:during startup program exited with code 0xc0000139

  • Hi,

    I want to build my app in release mode but at the end of the build I get the error message "during startup program exited with code 0xc0000139". In debug mode there are no issues.

    Looking through the web I found some post regarding this error. Here it was solved by upgrading Qt Creator. I already did that:

    Qt Creator 4.2.1
    Based on Qt 5.8.0 (MSVC 2015, 32 bit)
    Erstellt am Jan 20 2017 01:29:39
    Revision 7071b61e02

    I am on a Win 7 64bit machine. Here is a screen shot of my release kit. There is an error regarding CMake could this be the cause?

  • Lifetime Qt Champion

    @Sikarjan "during startup program exited" - can you explain what exactly are you doing? Do you want to build AND start your app (Ctrl-R)? Or only build?

  • I want to build and run. If I only do a build everything is fine, no errors.
    I forgot to mention that I tried clean project and build all as well.

  • Lifetime Qt Champion


    Can you check with Dependency Walker whether there's something fishy with your application ?

  • I already did that. Following a youtube tutorial. I noticed that my error messages looked different. Not only dll were missing also other things were listed. After adding the gui and core dll to the folder I had still errors. I can make a screenshot on Monday.

    Today I compiled my app in release mode on Mac OS X. This works fine. No errors, app is running nicely.

  • Lifetime Qt Champion

    You should check whether one of the folder listed in the PATH environment variable also contains Qt .dlls.

  • Thanks for the hint. On my Windows system the system variables are blocked and cannot be edited. I guess the missing path variable was the root cause.

    To solve my issue I added the path variable as outlined here in my user specific variables.

    I also rechecked the dependencies with Dependency Walker. After adding the Qt5Core, Qt5Gui and Qt5Widgets dlls to the release folder I still get tons of errors. Since the program does start I am not sure if I need to worry about these errors. Is this a 32 vs. 64 bit issue?

  • Lifetime Qt Champion

    Don't modify your PATH to include Qt.

    What exact error ? Did you also deploy the plugins ? Like the platform plugin ?

  • Hi,

    I did not modify it. In my path variables there was nothing about Qt. System PATH is block and cannot be edited. So I assume Qt could not set it during installation.

    Regarding the errors see the linked screen shot.

    Not sure what you mean with deploy plugins. Knowingly I did not do such a thing.

  • Lifetime Qt Champion

    There's no PATH variable modification involved when installing Qt.

    Looks like you are using the MinGW Qt version which is 32 bit. Do you have any dependency on your application ?

    Where did you copy the .dlls for ?

    If you didn't deploy the platform plugins with your app it won't start.

    Did you took a look at windeployqt ?

  • I followed this tutorial and currently the app starts as expected.

    No I did not take a look at windeployqt, yet.

Log in to reply