Problems running OpenGL libraries

  • Hey guys!
    I'm working on a little program with OpenGL and Qt, and when I tried to compile it I got the following error:

    QSurfaceFormat: No such file or directory

    I've already tried installing different libraries but nothing. I'm running the latest version of Linux Mint on a 64bit architecture and my Qt version is:

    Qt Creator 3.5.1 based on Qt 5.5.1

    I'd really appreciate any help.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    That's not a Qt version you are giving here but the Qt Creator version which is independent from the version of Qt you are using to do development.

    Which version is in the Kit you use for development ?

  • Sorry! My bad, here's my Qt version:

    matias@Angband ~ $ qmake -v
    QMake version 3.0
    Using Qt version 5.5.1 in /usr/lib/x86_64-linux-gnu

  • Lifetime Qt Champion

    Can you share your project .pro file ?

  • Sure

    # Project created by QtCreator 2017-01-08T19:45:54
    QT       += core gui
    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
    TARGET = grieta
    TEMPLATE = app
    QMAKE_CXXFLAGS += -std=gnu++11
    # The following define makes your compiler emit warnings if you use
    # any feature of Qt which as been marked as deprecated (the exact warnings
    # depend on your compiler). Please consult the documentation of the
    # deprecated API in order to know how to port your code away from it.
    # You can also make your code fail to compile if you use deprecated APIs.
    # In order to do so, uncomment the following line.
    # You can also select to disable deprecated APIs only up to a certain version of Qt.
    #DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x060000    # disables all the APIs deprecated before Qt 6.0.0
    SOURCES += main.cpp\
    HEADERS  += mainwindow.h
    FORMS    += mainwindow.ui

  • Lifetime Qt Champion

    Use CONFIG += C++11 if you want C++11 in your projects prior to Qt 5.7.

    Other than that, that part looks good.

    Did you check that you installed all the dev package for Qt development ?

  • I think I have, at least all the ones I need for this, but to be honest I don't know how to make sure that there's no a missing one.
    I've also had problems with the QPointF, QVector and QImage classes (maybe that info helps to point where's the problem).

  • Lifetime Qt Champion

    QImage comes from QtGui but gui is already installed as it seems.

    Which Qt package do you have on your system ?

  • This post is deleted!

Log in to reply