Nominate our 2022 Qt Champions!

LSOpenURLsWithRole() failed with error -10825

  • i'm just trying Yosemite out for the first time,
    OSX 10.10.5
    xcode 7.2.1

    after compiling app with qt 5.3.2 the app fails to open giving

    LSOpenURLsWithRole() failed with error -10825

    which i believe to be related to being an incompatible OS version.

    to get rid of various errors regarding building for older version,
    i updated the files "Qt5.3.2/5.3/clang_64/mkspecs/qdevice.pri" and "Qt5.3.2/5.3/clang_64/mkspecs/macx-clang/qmake.conf"

    to both feature


    also xcode 7.2.1 has

    so I'm wondering if these are causing the file to fail to load in 10.10.5

    edit. due to noob restraints i cant reply quite yet
    i just noticed that
    otool -l
    reports min version as 10.11


    cmdsize 16
    version 10.11
    sdk 10.11

    i also tried this flag

    QMAKE_CXXFLAGS += -mmacosx-version-min=10.8 -arch x86_64 -isysroot /Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.11.sdk

  • Lifetime Qt Champion


    You have modified your mkspec telling it that your application should deploy on 10.11 as a minimum yet you are running macOS 10.10.

  • I have the same problem:

    I haven't touched mkspecs.

  • anything other than setting


    i get errors such as
    ld: warning: object file (build/moc_monitoreddatamapper.o) was built for newer OSX version (10.10.5) than being linked (10.10)


    Undefined symbols for architecture x86_64:

  • some more info.
    i've been testing numerous settings, and i have a version reporting
    cmdsize 16
    version 10.10
    sdk 10.11

    now this version as built will not run on the system it was built (10.10.5) (giving error in thread title)

    but it runs fine in 10.8
    AND if i duplicate the non-working app, the duplicate will then work on 10.10.5

  • Lifetime Qt Champion

    If you want your application to only run starting with 10.11, then why develop on an older version of macOS ?

  • @SGaist said in LSOpenURLsWithRole() failed with error -10825:

    If you want your application to only run starting with 10.11, then why develop on an older version of macOS ?

    xcode 7.2.1 (which is the latest version compatible with 10.10), only ships with 10.11 sdk
    so there is an obvious discrepancy in version numbers

    i want compatibility with 10.8 at least.

    the initial problem was being able to compile succesfully in 10.10.5

    which seems to be working now .. but in the process for max compatibility i'm symlinking to the 10.8 sdk now with other modifications that make my question irrelevant now.
    out of interest i will try and work out where in the process things started going the correct way.

  • Lifetime Qt Champion

    The SDK against which you build your application and the deployment target are more or less independent.

    Unless you start using a feature only available since a specific version of macOS you can target older versions for deployment.

Log in to reply