How to "follow symbol" into c file



  • Hi,
    i am working on a legacy project on a legacy platform. All the definitions are in C files. The "follow symbol" option does not work.

    I tried with eclipse and it is able to follow the symbols in the project.

    How to make this work in QT Creator as well?

    Linux Mint, QT Creator 3.2.2

    Thanks!


  • Moderators

    Hi! Update to the latest version of Qt Creator and try again.



  • Hi,
    where can i download the latest QT Creator for 32-bit Linux Mint?

    Ok, tried with 4.2.1. in Windows, the issue still exists. I imported a c project an i use QT Creator just for editing. I can see that it populated the .includes fiels with all the correct directories but F2 still does not work.


  • Lifetime Qt Champion

    Hi,

    There's no pre-built 32bit Linux package for Qt Creator. You'd have to build it by hand if Mint doesn't propose a more recent version.



  • Hi,
    i am now using Qt Creator 4.2.1. The issue still persists. I checked that all the folders that contain c files have been added to the .includes file.

    Is there anything else i can do to resolve this issue? Is Qt able to handle symbol resolving if header files are not included at the top of c files?

    P.S. i cannot change the way it is made, it is a legacy platform which works by including c files. The additional c files themselves don't include anything.


  • Lifetime Qt Champion

    Then that's likely a use case not supported by Qt Creator's code model.

    You should bring this to the Qt Creator mailing list. You'll find there Qt Creator's developers/maintainers. This forum is more user oriented.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.