Important: Please read the Qt Code of Conduct -

Android SDK missing tools

  • Is anyone else experiencing this error?

    Cannot find template directory ~/Android/Sdk/tools/templates/gradle/wrapper
    08:22:26: The process "~/Qt/5.8/android_armv7/bin/androiddeployqt" exited with code 3.

    It appears the latest Android SDK changes the contents of ~/Android/Sdk/tools/ directory considerably. If I copy back the tools directory from another PC where I have not updated Android Studio/SDK my Qt Android builds work. Also note that when my Android SDK is in the non-functional configuration I cannot select the android build SDK on the Project Kit configuration screen. QtCreator appears to expect android tooling in a specific location and it has moved or been removed from the SDK. The other possibility is I'm losing my mind and forgetting to install a requirement. :-/

  • Lifetime Qt Champion


    You mind is likely at the right place.

    Google as modified the layout of it's SDK/NDK in past so you may have found something new. You should probably check the bug report system so see if there's already something about for the Qt Creator project. If not, please consider opening a report with all the details you have about the changes.

  • Thanks @SGaist! Good Advice. Looks like bugs have been filed.

  • Lifetime Qt Champion

    Thanks for the link !

  • Just reinstall qt/android on another machine. Having the same issue.
    Does there is some hack to make it works? (didn't see anything in the bug report)

  • Lifetime Qt Champion

    @tom8oe wrote that he copied the tools folder from another working install and it worked for him.

    Which version of the SDK do you have ?

  • It looks like the SDK Command line tools 25.2.3 available on googles site contains the necessary tools. Look all the way at the bottom of the page: .

    If Google changes the webpage you can probably still access it via the download link:
    I was able to change the version number in the URL and download older versions not displayed on the web page.

    I overwrote my Android/SDK/tools directory with the tools from that download (I'm on Linux not sure if there are platform variations here) and everything worked. Also I got a new update from Android Studio today SDK Tools 25.2.5 and when that installed it appears to still contain the necessary tools. Maybe the earlier update was incomplete.

  • Qt Champions 2016

    @tom8oe from QTBUG-59236 it seems 25.2.5 is the latest working with Qt.
    there are also download links for macOS, Windows, Linux

  • @tom8oe, thanks this worked for me, although I only copied across the "templates" folder from the 25.2.3 SDK to, in my case ~/Android/Sdk/tools.

  • Hi ,

    I have re-installed Qt5.8 and android-sdk-linux tools r25.2.3 as described in the earlier postings.
    In my project I need to upgrade from supporting Android 6.0 to Android 7.0 (Nougat) since my Tablet device has been updated to Nougat.
    Inside the Qt Creator, I am getting a problem when trying to edit the Manifest file. It does not give me a choice to select Android 7.0 when selecting the minSdkVersion/targetSdkVersion. If I manually set it to version 24, Qt Creator changes it to "Not Set".

    Am I missing something here ? How do I get Qt Creator to select Android 7.0 in the settings ? My Build Settings are set to Android Build SDK android-25

Log in to reply