Qt World Summit: Register Today!

Is it QT-creator-win-opensource-2.2.1 intended for the Destkop?

  • Hello,
    After launching a recently installed Qt creator (2.2.1) I created a new project, the target setup only shows Symbian Device and Qt Simulator. (I know that if I install QT SDK, the QT creator shows the desktop option, but I am running against other obstacles with QT SDK, so I want to try other variants).

    I want to build for the desktop, Do I have to configure Qt creator and rebuild it from sources to get support for desktop?

    Thank you very much,

  • Do you have Qt 4.7.* libraries installed in your machine, or if its already there do you have it added to Qt Creator.

    To check, In Qt Creator => Tools => Options => Qt4 => Do you see Qt 4.7.* for Desktop - MinGW/MSVC*

    If not, click Add button and select qmake.exe file which should be under your QtInstallPath\4.7.3\bin.

    If you don't have Qt Binaries itself, you can download them from http://qt.nokia.com/downloads

  • Thank you very much Vijay,

    I have the libraries, but inside qt creator (tools->options->qt4) was pointing to the wrong place. I fixed it and now the message changed to "Qt version is not properly installed, please run make install".
    That messages is right below the "qmake location", where before the fix was saying qmake not found.
    What exactly I need to do to "make install" and in what directory?
    Please advise,

    Thank you very much,

  • Which Qt Libraries you have.. MinGW version or MSVC version?

    If you have Qt Libraries compiled with MinGW, you need to get MinGW installed and add path to g++.exe in "Tool Chains".

  • Thanks!
    I have teh QT libraries compiled with MinGW. But it really seems that after so many days struggling to have a 100% working Qt environment my system (and my head) is a total mess. I am working with 3 different systems at the same time (one real PC and 2 virtual PCs, all with windows 7 installed on it).
    I have had partial success, and unfortunately I have not been able to be consistent in the installations, as I said my head is already a mess.I am not a real programmer, so please bear with me, I will tell you exactly what I did from zero and maybe you can or someone else find the problem.

    Goal: Integrate opencv libraries (opencv 2.3) with Qt, and use QT creator to develop my application.

    I downloaded:

    1. cmake 2.8.5
    2. opencv 2.3
    3. mingw (sourceforge...at the moment it comes with g++/gcc 4.5.2)
    4. qt-win-opensource-4.7.3-mingw.exe (I understand that it comes with g++/gcc 4.4.0)
    5. qt-creator-win-opensource-2.2.1

    I have tried two different approches:
    First One:
    1)Install opencv 2.3 (all it does is extract itself to say: c:\opencv2.3)
    2)install mingw (I installed it on c:\mingw). Add c:\mingw\bin to PATH.
    3)Install CMAKE 2.8.5
    4)run cmake-gui, source folder c:\opencv2.3\opencv install folder: c:\opencv2.3. Genereate makefiles.
    5)go to c:\opencv2.3. Run mingw32-make and mingw32-make install.
    6)copy c:\opencv2.3\bin*.dll to c:\windows\system32

    7)Install qt-win-opensource-4.7.3-mingw (c:\qt). Add c:\qt\4.7.3\qmake and c:\qt\4.7.3\bin to PATH.

    8)Install qt-creator-win-opensource-2.2.1 (c:\qt...I will create folder c:\qt\qtcreator-2.2.1)

    9)In the tool chain of Qt creator now I manually add qmake location: c:\qt\4.7.3\bin\qmake.exe
    The message on the dialog screen says: Qt version 4.7.3, using mkspec win32-g++(Desktop).

    10)Now at this point if I create a QT Application Console, everything works. Debugging and running from inside qt creator or running the release version at the command prompt. It just works.

    Problems arises at the moment I try to use opencv libraries. I included the right INCLUDEPATH and LIBS values in the .pro file, so the project builds successfully without error.
    But If I try to run/debug (both) from inside Qt creator, I got the infamous - 1073741511 error.

    The other approach to installation I followed was to compile opencv with the mingw/g++ that is brought by the qt sdk (version 4.4.0)...but I have the same results (failure).

    Probably I am doing something VERY stupid, please try to look into my steps to see if you find the obvious.

    Thank you very much,
    Best regards,

  • I am not sure about this error.. May be I should try using opencv2.3 my self and see if it works.

    Did you try to add c:\opencv2.3\bin\ to PATH variable??

  • No, I haven't. I'll try that too...but now I uninstalled everything in one more attempt to start from scratch.
    But I found one thing that really might explains this whole thing: I found (in the qt website) that windows 7 as tier 1 is supporting MSVC 2008, it does not say about mingw....(see: http://developer.qt.nokia.com/doc/qt-4.7/supported-platforms.html )
    What does that means?

    I am installing MSVC 2008 express edition just to see.

    What do you think?

  • since MSVC 2008 is list for Windows 7, you should try MSVC 2008. May be there are some issues with Qt with minGW on Windows 7 platform!!

  • Thanks, that's what I am trying now..of course nmake will take longer that I can stare at.
    Best regards,

Log in to reply