Unable to debug and run due to configuration



  • I have installed Qt 5.5.1 on my Windows 7 64-bit platform. I have Microsoft Visual Studio 2010. When I open up my project in QtCreator and run the debugger, it basically starts and finishes immediately and my program does not appear to execute the display executable. I am sure this is a configuration issue but I am not experienced enough to understand how to fix it.

    My available kit is:
    Desktop Qt 5.5.1 MSVC2010 32bit (default)

    Qt Versions:
    Qt 5.5.1 MSVC2010 32bit C:\Qt\Qt5.5.1\5.5\msvc2010\bin\qmake.exe

    Compilers:
    Microsoft Visual C++ Compiler 10.0 (x86)
    Microsoft Visual C++ Compiler 10.0 (amd64)
    Microsoft Visual C++ Compiler 10.0 (x86_amd64)

    Debuggers:
    Auto-detected CDB at C:\Program Files (x86)\Debugging Tools for Windows (x86)\cdb.exe
    Auto-detected CDB at C:\Program Files (x86)\Windows Kits\8.1\Debuggers\x86\cdb.exe
    Auto-detected CDB at C:\Program Files (x86)\Windows Kits\8.1\Debuggers\x64\cdb.exe
    Auto-detected CDB at C:\Program Files \Debugging Tools for Windows (x64)\cdb.exe

    If I try to clone the auto-deteced kit and change the compiler to either (amd64) or (x86_amd64) I recieve the error

    The compiler "Microsoft Visual C++ Compiler 10.0 (amd64)" (x86-windows-msvc2010-pe-64bit) cannot produce code for the Qt version "Qt 5.5.1 MSVC2010 32bit" (x86-windows-msvc2010-pe-32bit).
    

    My project builds but then when I attempt to debug or run it, it crashes. I receive the error:
    "CDB PROCESS FINISHED, status 1, exit code -1073741515"

    Thanks in advance!



  • When I attempt to debug, this is what appears in the debugging output pane:

    starting debugger "CdbEngine" for ABI "x86-windows-msvc2010-pe-32bit"...
    Start parameters: 'Viewer' mode: 1
    ABI: x86-windows-msvc2010-pe-32bit
    Languages: c++ 
    Executable: C:\...\bin\Viewer_d.exe  [terminal]
    Directory: C:\...\bin
    Debugger: C:\Program Files\Debugging Tools for Windows (x64)\cdb.exe
    Project: C:\Users\name\Documents\PROJECT\develop
    Addtional Search Directories:
    Remote: :0
    Sysroot: 
    Debug Source Location: 
    Debugger settings: 
    QmlInspector.ShowAppOnTop: false  (default: false)
    ShowQmlObjectTree: true  (default: true)
    BreakOnAbort: false  (default: false)
    SelectedPluginBreakpointsPattern: .*  (default: .*)
    NoPluginBreakpoints: false  (default: false)
    AdjustBreakpointLocations: true  (default: true)
    SelectedPluginBreakpoints: false  (default: false)
    BreakOnFatal: false  (default: false)
    BreakOnWarning: false  (default: false)
    BreakOnCatch: false  (default: false)
    BreakOnThrow: false  (default: false)
    AutoEnrichParameters: true  (default: true)
    WatchdogTimeout: 20  (default: 20)
    GdbPostAttachCommands:   (default: )
    GdbStartupCommands:   (default: )
    MultiInferior: false  (default: false)
    WarnOnReleaseBuilds: true  (default: true)
    TargetAsync: false  (default: false)
    UseDynamicType: true  (default: true)
    BreakpointCorrection: true  (default: true)
    CDB_Console: false  (default: false)
    BreakOnCrtDbgReport: false  (default: false)
    BreakEvent:   (default: )
    AttemptQuickStart: false  (default: false)
    LoadGdbDumpers2: false  (default: false)
    LoadGdbInit: true  (default: true)
    IgnoreFirstChanceAccessViolation: false  (default: false)
    ListSourceFiles: false  (default: false)
    DisplayStringLimit: 100  (default: 100)
    MaximalStringLength: 10000  (default: 10000)
    AutoDerefPointers: true  (default: true)
    AllPluginBreakpoints: true  (default: true)
    EnableReverseDebugging: false  (default: false)
    SkipKnownFrames: false  (default: false)
    MaximalStackDepth: 20  (default: 20)
    IdentifyDebugInfoPackages: false  (default: false)
    IntelFlavor: false  (default: false)
    SortStructMembers: true  (default: true)
    ShowQtNamespace: true  (default: true)
    ShowStandardNamespace: true  (default: true)
    CloseMemoryBuffersOnExit: true  (default: true)
    CloseBuffersOnExit: false  (default: false)
    StationaryEditorWhileStepping: false  (default: false)
    RaiseOnInterrupt: true  (default: true)
    BreakpointsFullPath: false  (default: false)
    SwitchModeOnExit: false  (default: false)
    UseMessageBoxForSignals: true  (default: true)
    FontSizeFollowsEditor: false  (default: false)
    UseAlternatingRowColours: false  (default: false)
    VerboseLog: false  (default: false)
    LogTimeStamps: false  (default: false)
    AutoQuit: false  (default: false)
    ExtraDumperFile:   (default: )
    AlwaysAdjustColumnWidths: true  (default: true)
    RegisterForPostMortem: false  (default: false)
    UseAddressInStackView: false  (default: false)
    SourcePaths:   (default: )
    SymbolPaths:   (default: )
    AdditionalArguments:   (default: )
    GdbCustomDumperCommands:   (default: )
    UseToolTips: true  (default: true)
    ShowThreadNames: false  (default: false)
    UseCodeModel: true  (default: true)
    UseDebuggingHelper: true  (default: true)
    UseAddressInBreakpointsView: false  (default: false)
    UseToolTipsInBreakpointsView: false  (default: true)  ***
    UseToolTipsInBreakpointsView: false  (default: false)
    UseToolTipsInLocalsView: false  (default: false)
    State changed from DebuggerNotReady(0) to EngineSetupRequested(1) [master]
    QUEUE: SETUP ENGINE
    CALL: SETUP ENGINE
     Attaching to 6904...
     Launching C:\Program Files\Debugging Tools for Windows (x64)\cdb.exe -aqtcreatorcdbext.dll -lines -G -c .idle_cmd !qtcreatorcdbext.idle -p 6904 -pr -pb 
     using C:\Qt\Qt5.5.1\Tools\QtCreator\lib\qtcreatorcdbext64\qtcreatorcdbext.dll of 10/13/2015 4:47 AM.
     C:\Program Files\Debugging Tools for Windows (x64)\cdb.exe running as 6916
     Microsoft (R) Windows Debugger Version 6.11.0001.404 AMD64
     Using codemodel based breakpoint correction.
    Module loaded: Viewer_d.exe
    Module loaded: ntdll.dll
    Module loaded: ntdll.dll
    Module loaded: C:\Windows\SYSTEM32\wow64.dll
    Module loaded: C:\Windows\SYSTEM32\wow64win.dll
    Module loaded: C:\Windows\SYSTEM32\wow64cpu.dll
    <l+t
    <l+s
    NOTE: ENGINE SETUP OK
    State changed from EngineSetupRequested(1) to EngineSetupOk(3) [master]
    QUEUE: SETUP INFERIOR
    State changed from EngineSetupOk(3) to InferiorSetupRequested(4) [master]
    QUEUE: SETUP INFERIOR
    CALL: SETUP INFERIOR
    <sxn 0x4000001f
    <sxn ibp
    <.asm source_line
    <!qtcreatorcdbext.setparameter maxStringLength=10000 maxStackDepth=20
    <!qtcreatorcdbext.pid -t 0
    Taking notice of pid 6904
    NOTE: INFERIOR SETUP OK
    State changed from InferiorSetupRequested(4) to InferiorSetupOk(6) [master]
    State changed from InferiorSetupOk(6) to EngineRunRequested(7) [master]
    QUEUE: RUN ENGINE
    CALL: RUN ENGINE
    <g
    NOTE: ENGINE RUN AND INFERIOR RUN OK
    Running.
    State changed from EngineRunRequested(7) to InferiorRunOk(11) [master]
    Module loaded: WOW64_IMAGE_SECTION
    Module loaded: WOW64_IMAGE_SECTION
    Module loaded: NOT_AN_IMAGE
    Module loaded: NOT_AN_IMAGE
    Module loaded: C:\Windows\syswow64\kernel32.dll
    Module loaded: C:\Windows\syswow64\KERNELBASE.dll
    Module loaded: C:\Windows\SysWOW64\WINMM.dll
    Module loaded: C:\Windows\syswow64\msvcrt.dll
    Module loaded: C:\Windows\syswow64\USER32.dll
    Module loaded: C:\Windows\syswow64\GDI32.dll
    Module loaded: C:\Windows\syswow64\LPK.dll
    Module loaded: C:\Windows\syswow64\USP10.dll
    Module loaded: C:\Windows\syswow64\ADVAPI32.dll
    Module loaded: C:\Windows\SysWOW64\sechost.dll
    Module loaded: C:\Windows\syswow64\RPCRT4.dll
    Module loaded: C:\Windows\syswow64\SspiCli.dll
    Module loaded: C:\Windows\syswow64\CRYPTBASE.dll
    NOTE: INFERIOR EXITED
    State changed from InferiorRunOk(11) to InferiorShutdownOk(18) [master]
    State changed from InferiorShutdownOk(18) to EngineShutdownRequested(19) [master]
    QUEUE: SHUTDOWN ENGINE
    Process exited (3221225781)
    ERROR: Process crashed
    CDB PROCESS FINISHED, status 1, exit code -1073741515
    NOTE: ENGINE SHUTDOWN OK
    State changed from EngineShutdownRequested(19) to EngineShutdownOk(21) [master]
    State changed from EngineShutdownOk(21) to DebuggerFinished(22) [master]
    QUEUE: FINISH DEBUGGER
    CALL: SHUTDOWN ENGINE
    NOTE: ENGINE SHUTDOWN OK
    State changed from DebuggerFinished(22) to EngineShutdownOk(21) [master]
    State changed from EngineShutdownOk(21) to DebuggerFinished(22) [master]
    QUEUE: FINISH DEBUGGER
    NOTE: FINISH DEBUGGER
    HANDLE RUNCONTROL FINISHED
    Debugger finished.
    NOTE: FINISH DEBUGGER
    

    Still not sure how to fix this.


  • Moderators

    @configurationinquiry4 Can you execute your app without debugging?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.