Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

Qt-5.5.1 cross-compile for ARM



  • Hi,

    I am using arm based device i.e., IMX6 device, Now my requirement is to cross compile qt-5.5.1 for device.
    Can you please guide me how to configure qt-5.5.1 for my device.
    Thanks in advance.



  • Download the commercial version of Qt aka Boot2Qt or https://www.ics.com/blog/configuring-qt-creator-raspberry-pi https://wiki.qt.io/RaspberryPi2EGLFS this links may help you to get an idea



  • Hi Hakan AFAT,

    Thank you for your support, Now I am able to configure Qt-5.5.1.

    But Now I am getting issue during make, I am posting error what i am getting.
    Please go through it and give me a solution.

    In file included from ../../include/QtCore/qbytearray.h:1:0,
    from ../../include/QtCore/../../src/corelib/tools/qstring.h:42,
    from ../../include/QtCore/qstring.h:1,
    from ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:38,
    from ../../include/QtCore/qcoreapplication.h:1,
    from kernel/qt_gui_pch.h:53:
    ../../include/QtCore/../../src/corelib/tools/qbytearray.h: In member function 'void QPdfEnginePrivate::xprintf(const char
    , ...)':
    ../../include/QtCore/../../src/corelib/tools/qbytearray.h:98:19: note: the mangling of 'va_list' has changed in GCC 4.4
    make[3]: *** [.obj/qpdf.o] Error 1
    make[3]: Leaving directory /u01/Qt_src/qt-everywhere-enterprise-src-5.5.0/qtbase/src/gui' make[2]: *** [sub-gui-make_first] Error 2 make[2]: Leaving directory/u01/Qt_src/qt-everywhere-enterprise-src-5.5.0/qtbase/src'
    make[1]: *** [sub-src-make_first] Error 2
    make[1]: Leaving directory `/u01/Qt_src/qt-everywhere-enterprise-src-5.5.0/qtbase'
    make: *** [module-qtbase-make_first] Error 2
    *


  • Lifetime Qt Champion

    Hi,

    What version of gcc are you using to build Qt ?



  • Hi,

    We are using gcc-4.6.2 version.


  • Moderators

    @DivyaMuthyala It looks like you have a dirty Qt environment. Some objects were compiled with a different gcc.

    I would do a make clean and then reconfigure and remake.



  • Hi,

    I have done what you have said, still I am facing same issue.


  • Moderators

    @DivyaMuthyala Can you post the full build log or at least the part with the errors... That mangling thing is usually just a warning.



  • Hi,

    Now I am facing with following error:

    /u01/rootfs/usr/lib/libxcb-xkb.a: could not read symbols: File format not recognized
    co***llect2: ld returned 1 exit status
    make[6]: *** [../../../../lib/libQt5XcbQpa.so.5.5.0] Error 1
    make[6]: Leaving directory /u01/Qt_src/forImx6/qt-everywhere-enterprise-src-5.5.0/qtbase/src/plugins/platforms/xcb' make[5]: *** [sub-xcb_qpa_lib-pro-make_first-ordered] Error 2 make[5]: Leaving directory/u01/Qt_src/forImx6/qt-everywhere-enterprise-src-5.5.0/qtbase/src/plugins/platforms/xcb'
    make[4]: *** [sub-xcb-make_first] Error 2
    make[4]: Leaving directory /u01/Qt_src/forImx6/qt-everywhere-enterprise-src-5.5.0/qtbase/src/plugins/platforms' make[3]: *** [sub-platforms-make_first] Error 2 make[3]: Leaving directory/u01/Qt_src/forImx6/qt-everywhere-enterprise-src-5.5.0/qtbase/src/plugins'
    make[2]: *** [sub-plugins-make_first] Error 2
    make[2]: Leaving directory /u01/Qt_src/forImx6/qt-everywhere-enterprise-src-5.5.0/qtbase/src' make[1]: *** [sub-src-make_first] Error 2 make[1]: Leaving directory/u01/Qt_src/forImx6/qt-everywhere-enterprise-src-5.5.0/qtbase'
    make: *** [module-qtbase-make_first] Error 2
    ***

    I am configuring by using following:

    *./configure -commercial -confirm-license -opengl es2 -device linux-imx6-g++ -device-option CROSS_COMPILE=/U02/tools/DOP/imx6/freescale/usr/local/gcc-4.6.2-glibc-2.13-linaro-multilib-2011.12/fsl-linaro-toolchain/bin/arm-none-linux-gnueabi- -sysroot /u01/rootfs -no-gcc-sysroot -I/u01/rootfs/usr/include --hostprefix=/usr/local/Qt-5.5.0



  • @DivyaMuthyala

    what arm device do u use?



  • Hi,

    We are using linux based IMx6 SoloLite board.


  • Qt Champions 2018

    @DivyaMuthyala What does "file /u01/rootfs/usr/lib/libxcb-xkb.a" say?


  • Moderators

    @DivyaMuthyala You are definitely mixing binaries. I was suspicious before but I'm positive now with that last error.

    I'll wait and see what your response with the output of the file command is.



  • Hi,

    Thanks for your support.

    Now I am able to configure successfully,but now I am facing issue during compilation.
    When I am trying to compile sample application its throwing a following error.

    "fatal error: QApplication: No such file or directory"

    I am adding in .pro file QT +=widgets, but still I am facing issue.
    Can you please help me.
    Thanks in advance.


  • Lifetime Qt Champion

    Did you re-run qmake after adding that ?



  • Yes,I have run qmake and make


  • Lifetime Qt Champion

    Are you sure you did install your custom Qt properly ?



  • Hi,

    I have missed some library soft linking .
    I Configured it again and its working fine now.

    Thankyou for your support.


Log in to reply