Qt 5.8 Windows 10 64bit (Home) MinGW (GCC 6.3.0) compilation fails.



  • Hey there!
    I'm trying to compile QT static on a Windows 10 Home 64 bit machine using MinGW64 with GCC 6.3.0 and getting stuck during make.

    python --version
    Python 3.6.0
    ruby --version
    ruby 2.3.3p222 (2016-11-21 revision 56859) [x64-mingw32]
    perl --version

    This is perl 5, version 24, subversion 0 (v5.24.0) built for MSWin32-x64-multi-thread
    (with 1 registered patch, see perl -V for more detail)

    Copyright 1987-2016, Larry Wall

    Binary build 2400 [300558] provided by ActiveState http://www.ActiveState.com
    Built Jun 9 2016 21:44:59

    Perl may be copied only under the terms of either the Artistic License or the
    GNU General Public License, which may be found in the Perl 5 source kit.

    Complete documentation for Perl, including FAQ lists, should be found on
    this system using "man perl" or "perldoc perl". If you have access to the
    Internet, point your browser at http://www.perl.org/, the Perl Home Page.

    g++ --version
    g++.exe (GCC) 6.3.0
    Copyright (C) 2016 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    mingw32-make --version
    GNU Make 4.2.1
    Built for Windows32
    Copyright (C) 1988-2016 Free Software Foundation, Inc.
    License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
    This is free software: you are free to change and redistribute it.
    There is NO WARRANTY, to the extent permitted by law.

    Here's how I tried the whole thing:
    git clone git://code.qt.io/qt/qt5.git src
    cd src
    git checkout .
    git checkout 5.8
    cd ..
    mkdir 5.8s
    cd 5.8s
    ..\src\configure -static -platform win32-g++ -debug-and-release -opensource -confirm-li
    cense -opengl desktop -no-angle -make libs -qt-zlib -qt-libjpeg -qt-libpng -qt-freetype -qt-pcre -qt-harfbuzz
    mingw32-make -k -j8

    After about 30 minutes I get the following error:
    mingw32-make[5]: Target 'all' not remade because of errors.
    mingw32-make[5]: Leaving directory 'Q:/Development/Qt/static.5.8/qt3d/src/plugins/sceneparsers/assimp'
    mingw32-make[4]: *** [Makefile:38: debug-all] Error 2
    ar -M < object_script.libassimpsceneio.Release
    mingw32-make[5]: Leaving directory 'Q:/Development/Qt/static.5.8/qt3d/src/plugins/sceneparsers/assimp'
    mingw32-make[4]: Target 'first' not remade because of errors.
    mingw32-make[4]: Leaving directory 'Q:/Development/Qt/static.5.8/qt3d/src/plugins/sceneparsers/assimp'
    mingw32-make[3]: *** [Makefile:40: sub-assimp-make_first] Error 2
    mingw32-make[3]: Target 'first' not remade because of errors.
    mingw32-make[3]: Leaving directory 'Q:/Development/Qt/static.5.8/qt3d/src/plugins/sceneparsers'
    mingw32-make[2]: *** [Makefile:442: sub-plugins-sceneparsers-make_first] Error 2
    mingw32-make[2]: Target 'first' not remade because of errors.
    mingw32-make[2]: Leaving directory 'Q:/Development/Qt/static.5.8/qt3d/src'
    mingw32-make[1]: *** [Makefile:42: sub-src-make_first] Error 2
    mingw32-make[1]: Target 'first' not remade because of errors.
    mingw32-make[1]: Leaving directory 'Q:/Development/Qt/static.5.8/qt3d'
    mingw32-make: *** [Makefile:434: module-qt3d-make_first] Error 2
    mingw32-make: Target 'first' not remade because of errors.

    I literally tried all available configure options in the last 2 days and got stuck on different modules. So far this was my best attempt. Anyone could give me a clue what I'm missing would be greatly appreciated.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.