Nominate our 2022 Qt Champions!

Gdb crashes after updating to Qt Creator 2.2.1

  • My problem is exactly like the one previously reported in this thread: "":

    In short, I recently updated to Qt Creator 2.2.1 and gdb crashes when I try to debug a project that previously debugged fine in Qt Creator 2.1. The application output shows a lot of internal errors:

    (Internal error: pc 0x0 in read in psymtab, but not in symtab.)
    (Internal error: pc 0x6 in read in psymtab, but not in symtab.)

    I have tried clean re-installations on two different machines. I also tried to replace gdb by the versions provided here: "": but that did not change anything.

    I'd already be happy if someone could give me a link to an older version of Qt Creator for Windows - I have trouble finding one. Also, if you can tell me where to find the debug log I'd be happy to provide it, but I can't find that one either.

  • You can find older versions of Qt Creator "here": . But maybe someone knows a solution to the actual problem.

  • Please "file a bug report":, attaching the complete debugger log. Thanks!

  • I'm sorry Tobias, I'm on a tight schedule and already reverted back to Qt Creator 2.1, where it again compiles fine (thanks loladiro, much appreciated). Besides I have no idea where I would even find the debugger log, I checked several places.

  • Then it might or might not work in Qt Creator 2.3:-)

  • Well, It does not. I've just tried the beta.

    2010.5 works no problem, but after installing Qt Creator 2.2.1 the debugger crashes as explained. 2.3 beta is the same.

    I also noticed that if I don't start debugging directly but start the application normally than attach the debugger to the running code than there is no problem at all. The debugger runs smoothly.

    I also tried using the old tool chain and the old libs. Crashes all the same.

    It keeps printing this:
    (Internal error: pc 0x0 in read in psymtab, but not in symtab.)
    then dies.

Log in to reply