Important: Please read the Qt Code of Conduct -

[Solved]Adding QWT Library to Qt creator

  • Hi. Can someone explain me how to add the QWT Library to the Qt creator, so tht i can build plotting application like any other normal applications.

    Thank you.

  • What do you mean by "adding to Qt Creator"? It is IDE. Maybe you want to add it to your project?

  • Yeah.. Adding it to my project.

  • Look at qmake LIBS keyword in Assistant.

  • Creator even has an assistant for adding libraries.
    Open your .pro file and right click into the .pro file.
    Now you will see an "add library" item in the context menu.

  • I m working on linux platform. All I have is the .so files and all the header/class files. How to link it to the Qt creator project.

    I dont seem to have an add library option on right clicking my .pro file. Rather, I jus have an option to add some random files(C++ class , Resource file and the QML file).

    Is Qmake option similar to " LIBS += -L/usr/local/lib -lmath" ??

    Please help.

  • [quote author="Vijaeendra" date="1310362001"]

    Is Qmake option similar to " LIBS += -L/usr/local/lib -lmath" ??

    yeah, you are right.

  • I m facing a trouble at the linking phase. I have added a DEPENDPATH to my library file.., the .so file names are as follows..,

    I tried
    LIBS += -llibqwtmathml, which is not working.

    I also tried giving the complete path but did not help.
    Can u please help me in adding this .,

  • My .pro file is

    QT += core gui

    LIBS += -llibqwt

    TARGET = plottrial
    TEMPLATE = app

    SOURCES += main.cpp

    HEADERS += plotmatrix.h

    INCLUDEPATH += /home/viju/Desktop/qwt-6.0.0/src

    DEPENDPATH += /home/viju/Desktop/qwt-6.0.0/lib

    FORMS += plotmatrix.ui

  • Well, It should be

    LIBS += -L//home/viju/Desktop/qwt-6.0.0/lib -lqwt

    But I still have dynamic linking problem.

  • bq. I m working on linux platform. All I have is the .so files and all the header/class files. How to link it to the Qt creator project.

    What Linux are you on and what version? This can be important to know because not all linux boxes use the same way to let the run-time linker known the path to a shared library .

  • Ubuntu-10.10


  • In that case I think i can help you out. I've succeeded using QWT in kubuntu 10.10 and had to look at the ubuntu help pages to solve it out. So it should work for you too.

    of course you have to adapt the paths.

    in shell :

    1. Add the configuration file :
      echo "/usr/local/qwt-6.0.0-rc5/lib" | sudo tee /etc/
    2. Update the cache :
      sudo ldconfig -v

    put this in your pro file :


    QWT_LOCATION = /usr/local/qwt-6.0.0-rc5/

    INCLUDEPATH += $${QWT_LOCATION}/include/
    LIBS = -L$${QWT_LOCATION}/lib
    If you later decide to "uninstall" the libraries, just remove the conf file and run sudo ldconfig again.

  • Can u please explain the command . I have qwt folder on the desktop. also there isnt qwt.conf file.
    I m not able to edit any of the configuration files. But, I m sure once i add this path it ll surely work.


  • Did you compile qwt?

    If not open the pro file in Qt Creator and compile it.

    Then follow my instructions.

  • I have compiled Qwt, I m able to run all the qwt example projects too. But i cant find qwt.conf file.

    I need to know the exact procedure for gaining rights to edit the configuration files.

  • Did you follow my instructions? You have to do that first.

  • Yeah I did.. I got it.

    I had to change LD_ LIBRARY _PATH.

    Thanks for the help.

  • Glad to hear that.

    Could you please add [solved] in your title?

  • Hi..I have gone through the above discussion as I am facing the same problem(using qwt with qt creator).
    I have downloaded qwt-6.0.1 package,but I am unable to install it.
    I am using ubuntu 10.10.
    When I 'qmake' it succeeds,but when I 'make' it it gives fatal errors like "qdebug.h No such file" etc..
    What should I do?

  • There is a qwtconfig.pri in the source containing all the options you can modify when building it.

    By default, Qwt builds .prf files that contains necessary settings to use in you project's .pro file. If you set them correctly, you can set the necessary libs and includes by adding

    @CONFIG += qwt@

    in your .pro file.

    There are two ways to let qmake detect these .prf files. qmake searches for .prf files in certain locations, so you can either:

    1. Instruct Qwt to copy those files into the default search paths when it is built.

    2. Add Qwt's feature path into qmake's searching paths.

    3. Manually copy those feature files into qmake's search paths.

    4. is the easiest. Just uncomment this line
      in qwtconfig.pri, and then build it (qmake, make, makeinstall).

    If you don't want to install Qwt every time you upgrade Qt, you can use 2. or 3. instead. By default, the feature files are in a feature folder in Qwt's install path. Those are the configure files you need qmake to find. The correct paths to setup (or copy files into) are detailed in Qt "documentation":

  • Hey,thanks.I will try this out.
    Meanwhile I found on web that qwt-6.x version is compatible only with qt4.4 and above.Is it because of this that I am getting that errors as I am using qt3 / qt4?

  • I have tried out most of the things but no success so far.Here's my situation:
    I have Qt creator in which I can add a qwt_plot (widget),so I guess Qt creator has the the qwt plugin.
    But when I try to use any slot of qwt_plot, it gives errors.
    So I guess Qt creator is unable to include the QwtPlot class.
    Anybody has any idea how to solve this problem?

  • I would stop trying to use it with Qt3 as you already stated yourself it's not compatible.

    What version of Qt4 do you use? How did you install it?

Log in to reply