Qt World Summit: Submit your Presentation

QtMultimedia in QML weird error

  • Hello. After about 2 years of working only with widget-based apps I returned to QML. But after messing around I encountered a weird error (bug maybe?).

    My component looks like this:

    import QtQuick 2.7
    import QtMultimedia 5.7
    Item {
            anchors.fill: parent
            color: "grey"
            id: introplayer
            //source: "qrc:/videos/logo.mp4"
            Component.onCompleted: console.log(introplayer.status)
            onError: console.log(errorString)
        VideoOutput {
                 anchors.fill: parent
                 source: introplayer
        MouseArea {
                 id: playArea
                 anchors.fill: parent
                 onClicked: {introplayer.play(); console.log(introplayer.status)}

    This code compiles and kinda works, but gives me a error/warning, something like:

    IGIESW "path_to_exe" found in whitelist: NOIGIWHW Game "path_to_exe" found in whitelist: NO

    And the video doesn't play. Commenting the "source:" changes nothing, the message still remains, meaning that the mp4 itself probably isn't the problem (also tried wmv, same).
    There are no other errors, status outputs normally, showing that the video had already been played (or not loaded, without "source:"). I've checked the Qt+= multimeda part, it's there.

    So far I've tried:

    • Cleaning, rebuilding, etc. (I also did a clean install pretty recently)
    • Changing QtMultimedia versions (5.5-5.7, all behave the same)
    • Different compilers: mingw and msvc (absolutely the same)
    • Googling (litteraly 6-8 pages of unrelated things)
    • Bashing the head against the keyboard (resulted in, mostly, headaches)

    Thanks in advance

  • I'm a bit late to the party, but I have the exact same issue.... Any new ideas?

Log in to reply