QtCreator 4.0.2 shipped with qt 5.7.0 x64 linux host package and Linux Embedded Remote Debugging issues



  • Issue with Linux-Embedded remote debugging faced since QtCreator 4.0.2 that ships with Qt5.7.0 linux x64 package (qt-opensource-linux-x64-5.7.0.run).

    Earlier packages don't have this issue (qt-opensource-linux-x64-5.4.1.run, qt-opensource-linux-x64-5.6.0.run). I am using this linux host version just for local host complilation and also for remote debugging on a qt5.4.1 or qt5.6.0 builroot environment with gdb server. Debugging have worked fine until i changed to QtCreator 4.0.2. When setting some breakpoints in an another subdir project (not the main startup project), the breakpoints are ignored. In the debugger log there is a message like : "no source file named: <correct path to source file tried absolute or relative paths>"

    Again i have no such issues with QtCreator 3.3.1 and 3.6.1.
    I am quessing an issue in the QtCreator 4.0.2 debugger plugin?

    Anybody knows something about this issue? Any ideas?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.