Add driver module to b2qt



  • Hi guys,

    Has anyone tried to add his own kernel module to b2qt?

    I am testing b2qt with my E3827 platform (not far from Intel NUC DE3815) and I'm having problem to boot to the demo application. (default. nothing added or changed from the b2qt repo) GUI is freeze and stay with a mouse cursor and white background shown only. I want to debug the issue with SSH via ethernet and I have a USB-to-ethernet adapter requires install driver module. I followed Chapter "Building Yours Own Embedded Linux Image" and get a Yocto repo, and I tried to add the driver module in a layer called 'meta-custom' as following:

    source -------- meta-boot2qt
    |
    -------- meta-intel
    |
    -------- meta-mingw
    |
    -------- meta-openembedded
    |
    -------- meta-qt5
    |
    -------- poky
    |
    -------- meta-custom

    • recipes-kernel
      |
      --------- my_mod.bb
      |
      --------- file

       my_mod.c
       Makefile
      

    This is what I used to do in a regular Yocto poky distro.
    However, seems it has to be differently because after I did

    bitbake b2qt-embedded-qt5-image

    it returns error:


    *** Configuration file ".config" not found!


    *** Please run some configurator (e.g. "make oldconfig" or
    *** "make menuconfig" or "make xconfig").


    make[2]: *** [silentoldconfig] Error 1
    make[1]: *** [silentoldconfig] Error 2
    make: *** No rule to make target include/config/auto.conf', needed byinclude/config/kernel.release'. Stop.

    Anyone knows correct recipe setups for adding modules to b2qt-Yocto repo?



  • I kinda solve the issue but no idea how and why it get resolved.

    First I delete 'tmp' folder to rebuild everthing from scratch. Then I add
    VERSION
    PATCHLEVEL
    SUBLEVEL
    in the beginning of Makefile which is not required in my regular Yocto project build because there's a patch for Makefile in the same layer (copy from the meta-skeleton)

    Then I build the module first (instead of the whole image), and it was built successfully. Next I build the whole image, and it's done successfully too.

    I wonder if there's race condition issue when I build b2qt image cause problem during the building process when I add my own recipe.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.