.qrc files are not always recompiled



  • Hi,

    When I create a hybrid QML/C++ project in Qt Creator, and place the QML files in resources, I can change a QML file, save the file, click build or run, and then NOT get the updated file built into the executable. This behavior is already known but nothing happend over the years. For me this is an annoying major bug.

    qrc files are not always recompiled

    Does maybe someone know a workaround for this?

    Best greetings...


  • Moderators

    @PowerNow
    have you tried to rerun qmake everytime you add a new qml file to your project as stated in the link you provided??



  • @raven-worx : Thxs for your fast response!

    I tried the following:
    1.) Restart computer and start afterwards Qt-Creator -> then it works for a while but nevertheless the failure comes back
    2.) Rename the filename.qml to _filename.qml -> same as above
    3.) Change from "Build Debug" to "Build Release" -> same as above
    4.) "Clean Project" + "Run" -> same as above
    5.) As you ment and I overlooked, described in the bugreport, everytime I insert a new .qml file I start "Run qmake" -> it seems that it work, yep!!! Hopefully its a sustainable solution/workaround.

    Best greetings...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.