Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt 5.7 - QSQLITE driver not loaded on debug kit



  • I'm trying to compile an application on Linux (Ubuntu 16.04) against a Qt 5.7 framework and with the Qt Creator 4.0.2; both were installed via online tool installer. And it's really annoying because the Release version doesn't raise error, but the Debug mode gives an unexpected 'Driver not loaded' error when the app try to use a SQLite database. Anyone has any clue? I think MAYBE the online installer only gives us the 'release' libs. Should I try to compile the framework again, debug and release mode?
    PD: Sorry for my bad english :D


  • Moderators

    @Kalebros
    please set the QT_DEBUG_PLUGINS env variable to a non-zero value and post the console output.



  • More strange things! I've set the QT_DEBUG_PLUGINS variable, but there's no output. So, I've deleted the build directory and rebuild all the app. Now it works, and I'm both perplexed and ashamed. Thanks!



  • False alarm, still not working :(


Log in to reply