Qt android deployment



  • Hello,

    I'm new to develop android app with Qt on Windows. When I run the famous Hello World, to the AVD I created before, I got the message below. Any idea ?

    "Error while building/deploying project Essai (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.7.0))
    When executing step "Deploy to Android device"

    Thanks in advance.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You have to provide the full error message in order for us to be able to help you.



  • But it's the full message from the "Compile Output" window in Qt.


  • Lifetime Qt Champion

    Are you able to build your application ?



  • Yes the build was successfull. Could be something with the AVD used ?



  • I've been installing built apks to devices using the android SDK's abd from the commandline (not a fan of IDE's; oldschool, me). e.g:

    ~/download/android-sdk-linux/platform-tools/adb install deploy/bin/QtApp-debug.apk
    

    where deploy is the folder androiddeployqt built.

    Does that give you any more informative errors? (For example, I know it'll tell you an install fails when you try and install an ARM binary on an x86 emulator).



  • I think it is something with the AVD I created. Because I tried to create several AVD and one time, the deployment was ok. But now, I don't remember what I tried...



  • Hi again,

    I tried with a command line and got the following error msg.

    C:\Android\Projets\build-Essai-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_0-Debug\an
    droid-build\bin>adb install deploy qtapp-debug.apk
    [100%] /data/local/tmp/qtapp-debug.apk
    pkg: deploy
    ver: /data/local/tmp/qtapp-debug.apk
    Failure [INSTALL_FAILED_INVALID_URI]

    Any idea ?



  • Hi,
    one possibility might also be that there is a problem with the AndroidManifest configuration.
    For example a wrong invalid android package name (with invalid characters) or a minSDKVersion setting that does not support the device.

    Maybe checking the manifest configuration helps to find the issue?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.