Having issues starting a majority of QT-created apps



  • I'm sorry ahead of time if this is the improper forum for this - I'm not a developer and I've got no knowledge in developing QT apps, but I'm at the end of my rope and this seems to be the only centralized place on the internet to contact QT experts or those knowledgeable in it.

    Basically, a few different programs are crashing and throwing out errors in my Windows Event Logs with the faulting module as something related with qt5. It's different between apps, I believe, but they're generally preceded by qt5. Off the top of my head, one is QT5core.dll, I'll have to check again for the others, if it is important.
    Before my first reinstall, I ran just about every virus scan known to man alongside three different rootkit detectors with, predictably, no results.
    The apps that it has affected so far - EAC (EasyAntiCheat) - I'm completely unable to start EasyAntiCheat, so any game that uses it is out of the question. This includes Hurtworld, Rust, among others.

    The HTC Vive installer crashes before it starts. Also pointing to a QT5core.dll fault.

    ReVive, an overlay to add Oculus games to Steam VR, crashes before starting and fails to do what it needs to do. This one points to a different QT5 dll, but I can't remember it off of the top of my head.

    Stellarium is also giving me issues. Usually it won't boot at all, but if it does, it gives me this error.

    The same (or similar) to the others.

    Steam VR, which is also built on QT, works, but the menu is buggy and often seems to display corrupted text instead of the actual menu items (for example, "options" would turn into "Menu_Vive_Options" or something similar).

    Origin is crashing with the same error (even though it has worked in the past). When it doesn't crash outright, It's giving me this screen when I log in.

    What I've done so far:

    • Complete Windows format and reinstall (twice) as well as an in-place refresh (once).
    • RAM Test (Memtest overnight)
    • Prime95 CPU test (seven or so hours)
    • Revert from safe, stable overclock to stock (You know, just in case)
    • Multiple, exhaustive, virus scans, including Malwarebytes and a number of rootkit scans. Nothing at all. Of note, I haven't had a virus for over a decade, so this was just me being paranoid.
    • Uninstalled, repaired, and installed a whole slew of runtimes
    • Ran a chkdsk followed by an SFC scannow, followed by a DISM. No issues detected or repaired.
    • Per-app troubleshooting and compatibility tests
    • Changing the hard drive they're installed on. I've got a number of hard drives - I keep my gaming stuff separate from my OS. I doubt that would matter, considering a lot of people do this, but I was desperate.
    • Selective "clean boot" with no non-windows services or startup apps running.

    Somewhat related - what this guy and EKO, at the bottom of the thread, are encountering seem to be at least somewhat similar to some of the problems I'm running into.

    Thanks ahead of time for absolutely anything. I've been working on this issue for what feels like a month straight and I'm about to tear my hair out.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    One thing you can try is to download the latest Qt 5.7 using the online installer and then replace the .dlls in one of these application folder with the one from that installed Qt (also the plugin, platform and other folders containing Qt related .dlls).

    Hope it help keeps your hair safe.



  • Thanks so much for the attempt, but in an awful turn of events, I can't even install QT - the installer had odd graphical glitches (Checkboxes had no text), and then it crashed when I tried to install it.

    Nothing is safe from this bug I'm having, much less my hair, haha.

    No idea if this will help, but very typically, if a QT app doesn't crash outright, I see some weird corruption in the menu items.

    An example of this - Origin's title bar reads "application_name". Steam's VR interface will often totally go wonky, with every single item being a long descriptor like that instead of what is supposed to be there. Also, whole windows are sometimes completely transparent.


  • Lifetime Qt Champion

    Which version of Windows are you running ?



  • Windows 10, 64 bit, Version 1607, build 14383.187. That said, it's persisted for quite a while. I can't pinpoint exactly when it started, but I, at the very least, had it before the Windows 10 Anniversary Update.

    My first real run-in with the bug, I believe, was early June of this year upon attempting to get EasyAntiCheat working, although it's possible I had issues with it before and simply didn't connect the dots.



  • Hi two things to try:

    1. remove (or replace) your graphics card.
    2. try booting a Ubuntu USB-thumbdrive, install Qt on that and see if it works.


  • I'll give those a shot when I have a bit of time. Hopefully it isn't the GPU - I've got a GTX 970 and I'm not looking to upgrade any time soon.

    Thanks for the help!


  • Lifetime Qt Champion

    Are you using the nVidia driver or the one from Windows ?



  • Newest from Nvidia (which happens to be WHQL, I believe). Installed completely fresh with DDU. Not sure if it matters anyway - I removed my GPU to test and still came up with the issue using integrated graphics alone.

    I was able to get QT installed, as far as I could tell, in Ubuntu Live running from a USB stick, but I was getting errors along the way. You can see a crappy video I took with my phone of it here. Not sure if that's just a quirk in Ubuntu running off of a USB, or if it's a continuation of the issue I'm having with my PC. It seems as if other people are having those same errors on other distros, so I assume it's just a quirk from running it via USB.

    After I pushed through all of those errors, i was able to start QT on the live USB.



  • Huh, I looked at your video, lots of pain indeed. But if you can compile and consistently run some Qt examples on the Ubuntu stick, that would mean Windows is a bit loose.

    I'm no hardware guy, but you tested the processor and RAM. And now you've also tested without the GTX970 and still Windows 10 glitches out :-(

    Is it a Skylake processor? Some of these have issues with sleep and Intel's SpeedStep. Try disabling SpeedStep and advanced sleep modes in your BIOS. Also disable sleep in Windows. Just guessing :-)



  • Nope, Ivy Bridge - i5-3570k. I think I've disabled speedstep regardless, but I'll take a look. Can't hurt, at least. Thanks for the attempt!


  • Qt Champions 2016

    @darkaegis said in Having issues starting a majority of QT-created apps:

    Ivy Bridge - i5-3570k

    I have that exact processor (without overclocking though) and I haven't observed anything suspicious about it.



  • Ivy Bridge, then you should have a Turbo Boost setting in your BIOS? Try disable that also.



  • @kshegunov said in Having issues starting a majority of QT-created apps:

    I have that exact processor (without overclocking though) and I haven't observed anything suspicious about it.

    Yeah, same. It's actually worked fine for me for some time. Suddenly, out of the blue and without changing anything, I'm getting errors and crashes all over the place. It's infuriating.

    @hskoglund said in Having issues starting a majority of QT-created apps:

    Ivy Bridge, then you should have a Turbo Boost setting in your BIOS? Try disable that also.

    Sure do, it's actually what I was using to overclock. I had a slight overclock going for some time with the turbo boost numbers. Tested stable and cool for the longest time. That said, I've already reverted it to stock for test. I'll try dropping turbo boost if there's a setting.

    Update: Went as far as going with a fixed ratio, turned off speedstep completely, turned off turboboost. No dice.


  • Lifetime Qt Champion

    Any chance of having that since the Windows 10th Anniversary update ?


  • Qt Champions 2016

    @SGaist said in Having issues starting a majority of QT-created apps:

    Any chance of having that since the Windows 10th Anniversary update ?

    I'm with you on that. I'd always suspect software before hardware ... especially the video drivers ... and of course Windows itself ...



  • Unfortunately, at least some of the issues preceded the Windows 10 Anniversary update. The Vive setup was crashing as early as July 28th, when I got it, and EasyAntiCheat was crashing even before that (I posted about it looking for help on the Steam forums as early as June 4).

    I can't pinpoint when Origin started crashing on me, but I suspect it was relatively recently. I can say that the last game I played on it was about seven months ago, so there's a possibility it has been messed up for a while.

    I tried rolling back to 362 drivers, from March, for my GPU with no luck. I can try rolling back further, but I can't imagine others with the same GPU/drivers not reporting a similar issue at some point.

    I'm honestly not super far from demoting this stupid computer to media center and building another one, although I'm fairly certain my head would explode if the problems persisted after a new Mobo/CPU/GPU.

    That said, I'd be ecstatic if we were able to find a fix.



  • Hmm, perhaps it's time for some slight surgery (not on you but on your PC :):
    if you have 2 RAM memory sticks, swap them.



  • Was going to try that next, @hskoglund , even though they passed memtest, I figure it can't hurt to swap them, change channels, and remove one and then the other, just in case. I'm going to try that in a bit. Might have to head out for a job really quick for the time being, but I really, really appreciate all of the help you people are offering up.


  • Lifetime Qt Champion

    In the same kind of idea, did you try to change the PCI slot in which you put the graphic card ?



  • Tried RAM, no luck. Tried one of each, then switched slots. No luck. I definitely won't have time to switch the slot my GPU is in, but try that next.



  • @darkaegis maybe this is a good opportunity for you to switch to and learn Ubuntu (there are plenty of Steam games that work) :-))



  • Haha, I'm somewhat familiar with Ubuntu - I used it years ago in college and I dabble occasionally, but I've got far too many Windows-exclusive Steam games as well as Lightroom and Photoshop (for my job) that demand a Windows PC.

    Plus, many of the issues I've got right now revolve around Vive, which I hear has pretty close to zero Linux support.

    If anything, I'll probably dual-boot at some point in the near future, but I don't think I'll do it as a solution to my issue. :D

    Something just came to me, by the way - Origin recently overhauled their platform - presumably into qt5. That may have been why I didn't have the issue before but am having the issue now. I can't find a way to install the old version of Origin since they use a web installer and it downloads the newest version by default, but I can say that the graphical glitches and crashes I get in the newest installer aren't present in their older versions.

    Obviously I can't say it conclusively, but I can say that the problem seems to be restricted to applications made with Qt, regardless of how resource-heavy they are. Although I'm not sure why some Qt apps work with glitches and some crash outright.



  • Yeah agree. What about VLC for watching movies (another pretty well known Qt app)?



  • BTW, perhaps it's some specific Qt behavior that triggers the glitches. Now I'm thinking about the NX settings, have you tried disabling NX in BIOS?

    Edit: you can try it from inside Windows 10, open an elevated CMD window:
    bcdedit.exe /set {current} nx AlwaysOff



  • Yeah, VLC is actually my primary video player, and seems to be one of the Qt apps that doesn't trigger the behavior. I also use KeePass without error very regularly. I wonder if it has something to do with a specific version of Qt.

    I disabled XD in bios - no luck. Same results.

    And seriously, thanks again for all of the help. Even if we can't nail this down I appreciate it.



  • Let me know logs or anything might help. I'm willing to do whatever, at this point, to nail this down. A bit of extra info:

    The version of qt in the crashing Origin is 5.6.0.0.and it points to Qt5core.dll and I can (usually) get moments past logging in before crashing outright.

    The version of qt in the crashing EasyAntiCheat is 5.3.1.0 (although, technically, this one may not be related because I'm just getting a failure to start and no actual error in the event log, but it is inexplicably failing to start, so I can only assume that this is part of the issue)

    The version of qt in the crashing Stellarium is 5.6.1.0 and it points to qt5core.dll

    The version of qt in HTC Vive setup software is 5.5.1.0 and I don't even get a splash screen before starting. It also points to qt5core.dll.

    SteamVR uses 5.5.0.0 - and while it does work without crashing outright, there are weird text glitches in the menu, similar to what I see in Origin before it crashes. I'm unable to get to it at the moment, but this guy was having a similar issue and you can see what it looks like here.

    alt text.

    It'll often (but not always) look like that in every menu in the app, including settings. In addition, sometimes the background of the settings menu will fail to load and the whole window will be transparent.

    Videolan works fine and seems to be using an older version of Qt - Qt4, unless their documentation is outdated. Even so, their latest stable version is still old enough to come before this bug I'm having.

    Would this be a proper bug to submit officially to the bug tracker? Considering I'm not encountering it (seemingly) with any non-Qt apps on a very heavily used computer, I can only assume something is happening between the newest versions of Qt and my specific hardware/software setup.



  • Hi to submit it as a bug, best would be to have a small working, reproducible example.
    For example. if you could try download and install Qt on your Windows 10 and build a simple Widgets app (no coding necessary, just select a Widgets app and Build/Run.

    Then when you try to start that simple Widgets app and it glitches out, we're in business.



  • Unfortunately, since I think the Qt installer is based on Qt, it never makes it through completely. Sometimes it chokes when it's downloading the packages, sometimes it chokes on the "selection" screen, and sometimes it chokes halfway through installation, but it never makes it through completely without crashing or messing up to the point where I can't go any further. Similar story with the offline installation.

    I'll keep trying to install it, but I don't think I'll have any luck.



  • @darkaegis Oh for sure the installer app is 100% Qt.
    But if you another Windows PC around, you could install Qt and build a vanilla Widgets app on that PC, then run windeployqt on the .exe and copy the files over to your main culprit.



  • Ah, I should've thought of that. That'll be my next step. Thanks for the suggestion.



  • Are all of the applications that use Qt using their own copy of the Qt dlls? Did any of them add their directory to your PATH environment variable?



  • It does look like all of them are using their own copy of the Qt dlls. At least, for every app that I'm having errors, the Qt dlls are either within the application folder, or within a temporary folder created by the application (in the case of the Vive installer).

    I also realized something - a lot of the same errors I had on the Linux install, I had with the Windows install before it crashed or just didn't work outright. There's a possibility that my issues do extend to Linux, although it seems as if they were less severe since I was able to get the program running, at least.

    Installing it on my media PC right now to test. No errors at all, predictably.



  • Well, this is frustrating. I've built and successfully run chip, colliding mice, and Google Suggest with no errors or issues. Seems I need either something specific, something more complex, or both to trigger it.

    Problem is, since I have no idea how this all works, when I try to build more complex programs, they're starting blank because I have no idea how to compile and run them with their resources for use outside of Qt. As of now, though, I'm at a dead end. I'll attempt to build and run a few more of these over the weekend.



  • Well, from a Qt standpoint this is somewhat good news, I mean that simple apps perform nominally.

    Probably means that those more complex, real Qt apps use some additional resources that makes them go south. Have you tried some sound demo?

    BTW: have you got some fancy hardware plugged in to your USB connectors? Like video-camera? Pull 'em all out :-)

    Edit: also try removing your network cable. I know, I'm somewhat at my wit's end.

    Edit 2nd time: if you want to go full medieval on this one, you could try installing an older version of Qt on your media PC (say that 5.6.0 version that Origin is built with) and test some demos on that version on your Win10.



  • That's good to hear. I've run a few more QT apps in the meantime. Subsurface, which uses 5.5.1.0, Teamspeak, and Telegram seem to work fine, so no idea what might be triggering it at this point.

    I'll try a sound demo when I can get around to it. Wife is home, so the media center PC is occupied at the moment. In the meantime, I'll try unplugging everything from my USB drives. I don't have anything too fancy, really. Gaming keyboard and mouse, XQD reader, and Steam Remote dongle. I'll see how the games fare with everything unplugged.

    I tried disabling my NIC completely earlier, because Origin was hinting at some sort of network issue (igoproxy64 was faulting half the time), but I'll try unplugging ethernet as well.



  • I had a potential breakthrough. Well, at least it may help scratch a few things off of the "potential issue" list and push the "more complex apps" theory, unless it's somehow unrelated.

    I was kind of going down the list of Qt apps and seeing what crashed and what didn't, when I came to Marble.

    It didn't crash upon launch and was stable until I spun the "globe" around a few times, when it stuttered, then crashed on me. I was monitoring my CPU and GPU use in external programs - very little to no GPU was used for the app, but the CPU was hovering between 9 and 20 percent.

    Oddly, the first time it crashed pretty quickly, but the second and third times took a bit longer. I cleared the cache and it crashed again almost immediately, even though it doesn't seem to be using much more CPU. Every time I clear the cache it either immediately crashes or crashes in a few seconds.

    Not 100% sure what that would point to, but it's something, at least.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.