Qt 4.8 for INTEGRITY---> Configuration failed



  • Hello all,

    I am working with Qt4.8 for INTEGRITY.
    I created one batch file for configuring Qt for Integrity called configure.bat in the source directory .
    When I ran the batch file it is generating an error. I spent lot of time to resolve it but I could not able to solve it. so I am hoping to get solution by posting my problem here

    D:\Project\Qt4-ref>configure -embedded -xplatform qws/integrity-arm-cxarm -hostprefix D:\Project\Qt4 -ref -prefix / -qt-sql-sqlite -nomake examples -nomake demos

    Unable to detect the platform from environment. Use -platform command lineargument or set the QMAKESPEC environment variable and run configure again
    See the README file for a list of supported operating systems and compilers.

    As of I know that -platform for
    -platform <spec> ... The operating system and compiler you are building on. (default %QMAKESPEC%)

    -xplatform for
    -xplatform <spec> .. The operating system and compiler you are cross compiling to.

    Even I tried to by setting environment variables for Qmakespecs but no result. I dont know why its not working, qws/integrity-arm-cxarm is existing platform in QMAKESPEC.
    Please help me from this problem...

    Thanking you...


  • Lifetime Qt Champion

    Hi,

    AFAIK, the support for INTEGRITY was a licensed feature. I'd recommend bringing that question to the interest mailing list. You'll find there Qt developers/maintainers. This forum is more user oriented.



  • @SGaist I found the solution for it. If it is unable to find the platform implies that the problem with the Qmake path missing in the environment. For that we have to set the path.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.