[SOLVED] QtCreator 2.2.1 crashes when debugging



  • Hi all,

    I am having a problem with Qt Creator 2.2.1 crashing when debugging my application.
    I am using Qt SDK 1.1 with Qt Creator 2.2.1 (based on Qt 4.7.4 32 bit), From revision 74d015d2a9

    Whenever I start debugging it shows a message as "gdb-i686-pc-mingw32.exe has stopped working" and shows a message than "gdb process is crashed". Due to this Qt Creator 2.2 is completely
    unusable for debugging. It works well if I downgrade to QtCreator 2.1, which I don't want as I would like to work on the latest QtCreator. Someone can help me how to solve this issue.

    Thanks in advance,
    Srikanth


  • Moderators

    I would use the updater to go to the Qt SDK 1.2 . could be a version compatibility issue


  • Moderators

    It is GDB that is crashing from what I understand from your description, not Qt Creator. If that is correct: Try using the GDB from the old version of Creator if that one worked.



  • Yes, it is the GDB that is crashing. QtCreator is using python based debugger (from what I see from settings). I will replace QtCreator 2.1 pythongdb with QtCreator 2.2, and update the result. Feel free to push in more suggestions :)



  • You could post the debugger logs.


  • Moderators

    ... or actually "report a bug":http://bugreports.qt.nokia.com/ with the debug log attached ...

    That way the debugger people would actually see the issue.



  • When I think about it: Are there any firewalls active on the system, or anything else that might interfere with running processes?



  • Here is the "debug log":http://pastebin.com/gbqCBXfa.
    python is very well installed.


  • Moderators

    Are you using the GDB shipped with Qt Creator? Yours is of version 6.8 which does not yet support the Python scripting. You will need to fall back to the compiled debugging helpers for that compiler.

    PS: Please make sure to use the GDB shipped with Qt Creator: We tend to apply some patches that help a lot with what we need of the debugger.



  • I am using gdb shipped with QtCreator. The problem came after updating to 2.2, not sure about version 6.8

    Now I downloaded qtcreator-gdb-7.2-mingw-x86.zip from ftp://ftp.qt.nokia.com/misc/gdb/7.2/
    Now the app is launched under debug, but breakpoints not hitting :(

    Would like to know is it the correct gdb to use.



  • If gdb doesn't hit a breakpoint set by file name and line number the reason is in most cases that you try to debug a binary that was not compiled with the -g option (i.e. "is not a 'Debug' build). Make sure this option appears on the g++ command line in the "Application output" pane when (re-)building the project, or pastebin the contents of this pane.

    In any case, please also pastebin a new debugger log containing only one attempt to debug something. [The log at http://pastebin.com/gbqCBXfa contains a mix of a gdb 6.8 session, and some locally built gdb 7.2 that seems to have problems to find it's own pretty printers. Neither of these two versions of gdb have been shipped with Qt Creator, nor downloaded from ftp.qt.nokia.com.]



  • Removing all assert statements in the code solved the problem, sorry for the very long delay in updating the thread.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.